Global Mapper Pro

Display Error

mjmfgm
mjmfgm Global Mapper UserTrusted User
edited August 2008 in Technical Support
After I converted a shape file froam Area to Line style the data shifted. I used the Digitizer tool to select the shape file and used the "Create Line style from Area" tool?

Comments

  • global_mapper
    global_mapper Administrator
    edited August 2008
    I'm not sure I follow when you say that the data shifted. I wasn't seeing any shift in your screenshots. Perhaps I'm misunderstanding?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Please take a look at pict6 Mike and look at the numbers please, the are shifted.
  • global_mapper
    global_mapper Administrator
    edited August 2008
    Ah, this is because line features are labeled along the longest visible segment of the line itself, while areas are labeled at the center of the area. The line labels are taking precedence over the area labels, so you are seeing the labels along the boundaries rather than at the center of the areas.

    What you can do is go to the Line Styles tab of the Configuration dialog and select whatever line type you are using and disable the display of labels for that type.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Can't do that I need the labels to show up correctly, I tried to use the center option and that doesen't work either.
  • global_mapper
    global_mapper Administrator
    edited August 2008
    The labels would still show up for the area features if you just disabled them for the line type. The problem is now that the line labels are being displayed first and preventing the area labels from showing up.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Okay here is the problem, I was tying to convert the shape file to line style because of the custom types for cGPSmapper. I could not find a "polyline" type that I could use for the map.

    This started when I used the digitizer tool to select an area and export to "MP" format and use the gridding option / Use Selected Area Feature (s) for grid Cells and the exported "MP" files does not contain all the layer information. It uses the lower layer first and the top layer (area shape file as well ) is not displayed (please see piture7 )
  • global_mapper
    global_mapper Administrator
    edited August 2008
    I think in this case all of the layers are displayed, its just that the filled areas that are on top are covering up the underneath layers. What you can do is re-order your layers so that what you want on top is later in the control center's list of layers. You will also then want to go to the Vector Display tab of the Configuration dialog and select the option for vector layer ordering during draw to obey the order in the control center over type. This should get you the picture that you want, at least in Global Mapper and negate the need to create line features which aren't labeled like you want.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Nope still the same problem, I reordered the layers and made sure the option for Order of Vector Layers is checked.

    Don't know what ells it could be.
  • global_mapper
    global_mapper Administrator
    edited August 2008
    That is really strange. If you have re-ordered the layers so that the layer with the boundaries is after the one with the filled orange stuff and changed the vector display order during draw option, the boundaries should definitely show up on top in Global Mapper. If you uncheck the box for the orange stuff layer in the Control Center to hide it do the boundaries then show through.

    Can you send me the data files and save a workspace file so that I can take a look?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Yes of course Mike, I will do that tomorrow. I am working on a web site currently for a customer and could take 2 hours or so.

    I will post the data tomorrow morning, thanks Mike.
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Mike here are the files, please let me know what you came up with. Thanks Mike.:)
  • global_mapper
    global_mapper Administrator
    edited August 2008
    I took a look and realized that not all of your screenshots are from Global Mapper. I was thinking the issue with the orange data showing on top was in Global Mapper, but it looks like that is in the built maps, correct? The Garmin units themselves control what order the different area types are drawn in.

    To get what you want I suggest selecting all of the boundary area features, then right clicking and selecting the option to generate line features from the areas. Once that comes up, clear out the name option so that all of the lines will be created with no name, and make sure to assign your desired type that has a known MP_TYPE attribute value. This should give you the boundary areas to get the labeling that you want as well as boundary lines so that you can actually see the boundaries on top of the other data in the built map.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Most of the screen-shots are from GM10, there was one from GPSMapEdit. And yes the one we where talking about was the finished MP file.

    What I do is compare the maps between GPSMapEdit GM10 and Garmin Mapsource. The maps look the same in GPSMapEdit and Mapsource however; they look different in GM10.

    The labels do not show up in GPSMapEdit and Mapsource but do show up in GM10 ( As long as they are area shape ). The labels will show up in GPSMapEdit and Mapsource when they are line style shapes ( the labels are not aligned correctly )?

    So I will give the above procedure a try and let you know if this works now, thanks Mike for your help.
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    Mike this still does not work quite right, in order to export this to "MP" format using the Digitizerl tool and export using the "Gridding" option "Use Area Feature". (See Pictures)

    As you will see from the pictures I had to move the areas and the line shapes away from the Unit 1 so that the extra Labeling would not display, I think that by selecting an Area via the digitizer tool the tool is not calculating the Area correctly. Because when you select the line it selects both line features at the time. The Line features have two different names (i.e GMU1 and GMU2 as well as GMU201).

    That creates a whole lot of extra work of moving other line and area styles out of the way before you can select and export smale areas.

    Ps: I cannot find and "Undo" feature (i.e. ctrl Z or undoe button) ?
  • global_mapper
    global_mapper Administrator
    edited August 2008
    I'm not quite sure from your screensot why you are moving the areas around. Were they not positioned correctly or was it just the labels tat were not where you want them? Keep in mind for labels that Global Mapper doesn't have any control over where the GPS units display a label for a line or area feature, Global Mapper just associated the label with the feature and then the unit decides were to place the labels. If you want to absolutely place a label in a particular location you would have to create a point feature with the label that you want as points are always label directly at the point of course.

    There is not a true undo for anything in Global Mapper, but you can undo moving features by selecting the features, then right clicking and selecting the option to restore their original location.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mjmfgm
    mjmfgm Global Mapper User Trusted User
    edited August 2008
    The reason I am moving the shape area's is, If I am not then I get the extra labels. I explained that prior and made all kinds of notes in both of the pictures I posted.

    When I remove the areas then no labels are displayed in GPSMapEdit, Garmin Mapsource and on my GPS. If I leave them there then they are getting displayed in GPSMapEdit, Garmin Mapsource and on my GPS.

    Hope that helps for you to understand my frustration.
  • global_mapper
    global_mapper Administrator
    edited August 2008
    Did you make sure to remove the label for the line features that you created for use as boundary display? I have created a MP file myself from your data with no labels on the lines. I also classified the lines with the 'Processing/Closure Line' type to get an appropriate MP type.

    I have placed the file that I created at http://www.globalmapper.com/Incoming/mike_export.zip for you to try.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.