Global Mapper Pro

Geopackage EPSG codes issues - Global Mapper not reading correct EPSG code

yianni Global Mapper UserTrusted User

has anyone worked with geopackage files?

I recently received some imagery in that format and the provider said that the EPSG code was 3857 but when loaded onto GM it would load as 3397 and subsequently in the wrong location. If I was to use QGIS, the image would load as 3857 as per our requirements.

This is the first time ever that I come across something like that.

When using other software packages, ArcMAP and QGIS, the first image would always load onto 3857 as we were expecting to. Only in Global Mapper it loads as 3397.

Now It seems that I cannot reproject a geopackage inside Global Mapper so that created a whole load of issues with this image.

I went back to the provider and asked them to provide it to us in a different coordinate system and we agreed on EPSG 4326 which loaded fine, in the correct location etc in Global Mapper and in all other software packages.

The biggest difference between 3857, 3397 and 4326 is that the first two are Mercator systems and the last is Geographical.

 I feel that there might be an issue with Global Mapper and geopackage files and Mercator coordinate systems.

Note that I am still using v20.1 of Global Mapper.

any ideas?

thanks all

Best Answers

  • bmg_bob
    bmg_bob Global Mapper Programmer
    Accepted Answer

    Your best bet is to contact Blue Marble Support directly via email ( Please include the Geopackage file you are having the problem with. Thanks.

    In the meantime, can you post the Geopackage file here (or a link if it is too large)?

  • tikhpetr
    Accepted Answer
    yianni, hello!
    If you are still interested. I ran into a similar problem when loading an image in EPSG 3857 over the area in EPSG 20007(Pulkovo-95 GK 7 zone). The raster flew to the Horn of Africa, which is sad in itself.)). I used 2 ways to solve the problem:
    1. Restart GM several times (no more than 3 succeeded)
    2. Re-projected the raster in ArcMap
    Sorry my bad english. Good luck!


  • yianni
    yianni Global Mapper User Trusted User
    I have updated to the most recent version of Global Mapper, v 22.0 and I am still experiencing the above issues.

    Also the company that I work for has a a running service agreement with Blue Marble, is there a way to escalate / chase this up please? I think not reading the correct EPSG code is potentially a major issue with any GIS software package and it is puzzling that QGIS doesn't seem to confuse the EPSG systems.


  • yianni
    yianni Global Mapper User Trusted User
    Hi Bob,

    thanks for your response.

    As the imagery belongs to a client of ours I am not sure how much I can share. I will have to run the issue via a few channels.

    If possible I might be able to go to the imagery provider and ask for a smaller piece that could be easier to share and could keep project interests confidential.

    Will contact the email referenced above as well.

    All the best,

Sign In or Register to comment.