How to Find HOSTID of my machine


I'm in a pickle...

I'm using Global Mapper v20 single user node-locked license.  But my 1-year support has run out.  Last week, I deactivated my license and then reactivated it on the same machine the same day.  Everything worked fine and a message popped up to confirm that a license file had been generated. GM worked fine.

But the following day, I got a message that my machine HostID doesn't match the license.  I've tried various combinations of WiFi, network and docking-station access but none seem to give me the same machine hostID that I registered with, even though I'm using the same laptop with the same Windows install etc.  Unfortunately, I've already exceeded the three-activations-per-year, so I can't just type in my order number to reactivate the machine again (and, even if I did, I'm worried that the same thing may happen).

Can anybody tell me how to identify the Global Mapper HostID of my machine so that I can try various internet access / docking station combinations until I hit the one that I registered with?  Or does anybody know how I can get out of this mess????

Many thanks!

Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,148
    Answer ✓

    Typically, the HOSTID value in the license file is the MAC address from the network card or interface in effect when you license the software. This can be different depending on whether you are using a wired or wireless connection, or a docking station. One thing you might try, if you haven't already, is to start a command prompt and type "ipconfig /all". This will display information about all of the network cards it detects. Look at the value for Physical Address to see which one matches your license. Hopefully, that will be enough to help you figure out what configuration you were using when you licensed your laptop. 



  • Try it like this:
    Disk Serial Number (DSN) is a unique serial number assigned to the volume (s) of your computer’s hard disk, which can be used for licensing purposes. The following procedure will let you know your DSN and use it to install a license for NI AWR products.

    Open a command prompt. If you are not sure how to open a command prompt, open the Start menu, type cmd and press Enter.

    At the command prompt, type vol c: and press Enter.

    In the data that appears, find the 8-digit code designated as Volume Serial Number.

    The case does not matter; you do not need to copy the hyphen. In this case, you will need to enter 12abcd34 in the required field
  • Hi Tikhrpetr
    Many thanks for taking the time to reply.  But I'm afraid I already tried that.  I also tried the MAC address of my machine.  But neither look anything like the Global Mapper HostID.  I think Global Mapper looks at your volume serial number, your network card and (I've just found out to my cost) also looks at network hardware in any docking stations.  I tried to re-authorise GM whilst attached to a docking station and it seems to have generated its own temporary HostID.  That was my second re-authorisation of the year, so I now have a license which I can't use (even if attached to the same docking station, since the properties that generate the HostID are no longer recognised by GM).  Sub-optimal programming on GM's part.

    To be honest, I'm feeling a bit bruised by the experience.  Global Mapper is great software.  But the licensing that they use isn't very well thought-out.  They must get masses of support calls about it and end up with loads of grumpy customers because of it.  The licensing is there for their benefit, not ours.  We shouldn't have to suffer because of it.  Now, through no fault of my own, I've blown over 500 dollars on a piece of software that is disabled.  And all I get from GM support is "your one-year support has run out, so we can't help".

    QGIS is looking more and more attractive.

    Very grumpy. - but thanks!


  • Nice.  I'll definitely give that one a go.  Thanks very much indeed, Bob.  I'll let you know how I get on.

    Many thanks

  • Bob.  You're a bloody hero.  I owe you US$549!!!

    I went round all the desks at work, connecting to all the docking stations and testing them with the ipconfig command until I found the one that I must have registered with.  Global Mapper sprang into life and then I quickly de-registered it, disconnected the network cable and then re-registered on the WiFi.  It's all working fine now.

    Thanks very much indeed.  If you're ever passing through WInchester in the UK - I owe you a beer!

    If you've got any influence with the GM designers, it may be a nice idea to include a warning on the de-registering and licensing forms on the GM program to warn people not to use docking stations or USB network adaptors when de-registering or licensing.  I now realise that all the (many) licensing problems that I have had over the last two years have stemmed from using a netbook with no network adaptor (and always, therefore, using various USB network adaptors and docking stations when registering and de-registering).  I think most people would, like me, assume that the licensing computer-ID is linked to the computer itself, rather than the network adaptor.

    Thanks again!

  • Incidentally - I'm now not grumpy, am officially happy, and think Global Mapper is great again.  (I'm so fickle).
Sign In or Register to comment.