Overlay Control Center "Stuck" ????

Hi Folks. This is the first time this has happened, but I seem to have somehow got my Overlay Control Center (OCC) in the top left hand corner of my workspace. It was previously docked on the LHS but somehow I've double clicked and dragged it so that it has become un-docked and the top bar of the OCC is hidden/off the screen so I can't grab it and drag it back into view and re-dock it (see attached screen grab).

Any ideas on how to fix this as I'm stumped....???

Cheers, /al

Comments

  • Just to be clear, the OCC is stuck in upper LH corner of Windows desktop as per attached screen capture... (I'm running Windows 7 and GM V18.2). I've tried everything I can think of to move it, bit I'm stumped...
  • Ice Age MarkIce Age Mark Global Mapper User Posts: 309Trusted User
    Howdy,

    If you're familiar with doing such things, you might be able to go into the registry, where the location is remembered, and edit it to somewhere within your screen.  Then reopen.

    Good luck,

    Mark
  • Hi Mark,

    Sorry, I don't understand what you are saying...? Do you mean I should edit the registry via the Windows Registry Editor? I'm not sure I'd be confident enough to do that without messing up my whole computer. There must be another way...?

    ta
    /al
  • Ice Age MarkIce Age Mark Global Mapper User Posts: 309Trusted User
    edited October 22
    Hello there,

    I don't know any other way, but maybe BMG support knows some secret.  Even reinstalling GM will likely (though I'm not sure) not work unless you delete the entire GM registry.  The installer will try to save your old settings from there for you, including the problem CC location.  Plus you will lose every single custom setting, etc.  It's a real PITA.  You 'shouldn't' be able to wreck your whole computer just by editing the GM part of the registry.  If you get brave:

    Close GM before you edit the registry, otherwise when you do so afterward, it will just "remember" the old problem values, and you will have to start over.

    Type regedit in your RUN window or command line.  Navigate the file tree to find this place:

    Computer\HKEY_CURRENT_USER\Software\Global Mapper

    In 'Global Mapper' will be a giant list starting with 3D settings.  It's alphabetical, so scroll to the 'c' part and find "ControlCenter_Left" and "ControlCenter_Top".  Each one has a binary number followed by an integer in parenthesis.  The ones in parenthesis are the screen coordinates of the top/left corner of the CC.  If this is the problem, yours should be a value that is offscreen.

    Change these to a value that is near the center of your screen.  Close the registry, and reopen GM.  The CC 'should' be near the center, so you can then proceed and put it back where you want it.

    Best of luck,

    Mark
  • Hey Mark,

    I really appreciate your help and your very well explained instructions - thanks for taking the time!

    Unfortunately no joy, as I modified the CC values multiple times with multiple re-boots and nothing changed, see attached screen grab with modified CC registry values (same as I have on my laptop where i run another standalone V18.2). 

    I'm completely stuck. i can still use GM, its just a pain having the CC outside (left) of my work area... Maybe I'll see if the boffins at Blue Marble can help - though I think they no longer support V18.2 :-(

    Cheers buddy,
    /al
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,070
    Hello,

    Try deleting one or both of these keys from the registry (you may only have one -- I can't remember exactly which version added the second one.) They contain information about toolbar and pane locations that is stored automatically by Windows. This should restore default locations for all toolbars and panes. 

    HKEY_CURRENT_USER\Software\Global Mapper\Settings
    HKEY_CURRENT_USER\Software\Global Mapper\Workspace

    The "Workspace" key has nothing to do with Global Mapper workspaces.

    To be safe, you ought to back up your Global Mapper registry by right-clicking on the Global Mapper entry in the tree on the left, and choosing Export. This will create a .reg file. If you need to restore your registry, double-click that file in File Manager.

    Cheers,
    Bob
  • Hi Bob,

    Deleting the \Workspace sub folder was the answer. Many thanks!

    Cheers,

    /al

  • tikhpetrtikhpetr Posts: 18
    CarrickCon, maybe so try it?
Sign In or Register to comment.