Import PDF as raster layers

When importing a PDF as a raster image with 'Import each PDF layer to a separate GM Layer' I am only shown a single layer and prompted to rectify it. If I rectify the layer I am then prompted to rectify every single layer individually and I have no option to cancel. My PDF contains 103 layers so this is not practical and I have to use the Task Manager to exit GM.

Why do we need to rectify each layer of a PDF individually? 


Best Answers

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,038
    Answer ✓
    Hello,

    Does the prompt to rectify the image have an option to use the specified information for all imported layers?  If it doesn't or the option is being ignored, that would seem to be a bug. In that case, I suggest that you contact Blue Marble Support directly via email. Please include a detailed description of your workflow, and a sample PDF file that can be used to reproduce the issue.  Thanks.

    Cheers,
    Bob
  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,038
    Answer ✓
    Hello Steve,

    Upon further review, there is a way to avoid this when loading <filename>.pdf:

    1) On the first rectification dialog, after creating control points, save a .gcp or .pfw file named <filename>.gcp or <filename>.pfw (this is the default action when you choose File | Save ... on the rectification dialog.)

    2) On the first projection selection dialog, select the projection and put a check next to "Use Selected Projection for All Selected Files"

    The import will proceed without asking for any more information.

    Cheers,
    Bob
    sphillips

Answers

  • sphillipssphillips Posts: 125
    Thanks Bob.

    I have checked the options but it is just ignored so must be a bug. I'll contact them and send them an example.

    Cheers,
    Steve
  • sphillipssphillips Posts: 125
    bmg_bob said:
    Hello Steve,

    Upon further review, there is a way to avoid this when loading <filename>.pdf:

    1) On the first rectification dialog, after creating control points, save a .gcp or .pfw file named <filename>.gcp or <filename>.pfw (this is the default action when you choose File | Save ... on the rectification dialog.)

    2) On the first projection selection dialog, select the projection and put a check next to "Use Selected Projection for All Selected Files"

    The import will proceed without asking for any more information.

    Cheers,
    Bob
    Thanks Bob.

    I had a similar response from Blue Marble Support and it worked for importing PDFs as raster data. However, it does not work when importing the PDF as vector data. In fact the data extents came in as over half a billion kilometres across and obviously in the wrong location. I was able to fix this by Rectifying the vector data a second time though.

    Cheers,
    Steve
Sign In or Register to comment.