Batch Convert Bug

I am currently using Global Mapper version 18.2.2. 

The issue is when I try to batch convert shapefile to shapefile, I get the warning saying "You must select at least one type of data to be exported". This happens even when I have already added at least one shapefile in. I have also ticked all the 3 export area, line and point features option as per the screenshot below.

Not sure if this is a bug as I was able to reproject without any issue previously until I accidentally ticked the 3 options off today. After that, I am no longer able to batch reproject shapefile to shapefile. Even if I tick those options, nothing seems to change.

I have tried restarting my PC, reinstalling Global Mapper. 

Any assistance is much appreciated.


Best Answer

  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,158
    Answer ✓
    Hi Aaron,

    That sounds like a bug.  I suggest that you send a description of your workflow and results (you can send a link to this forum thread) to Blue Marble Geographics support via e-mail (  That will get your issue into the support stream, and facilitate a solution.

    In the meantime, you can reset the settings for the batch convert to their defaults by editing the registry. 
    1. Make sure Global Mapper is not running.  
    2. Using regedit, or your favorite registry editor, browse to HKEY_CURRENT_USER\Software\Global Mapper, and look in the list on the right for "BatchConvert_SettingsNew_Shapefile_to_Shapefile".  
    3. Right-click on that, and choose Delete from the context menu.  
    4. Start Global Mapper
    You should be able to run your batch convert again.



  • Hi Bob,

    Many thanks for the workaround. It has solved the issue.

    I have also sent an email to the support as suggested.

Sign In or Register to comment.