Global Mapper Pro

export to .ecw or .jp2 gives error in ArcGIS10.22

edited February 2016 in Raster Data
I have GM16.2, I can successfully export a clip of a huge .Sid file to a geotiff, and this works, but it is very large. I have exported the same extent to an ecw and jp2. They both open fine in GM, but give an error message in Arcmap "could not open the specified file" not a very useful message. has anyone else experienced this. I am on Win7, 64bit.
Edit:  Actually, I just tried it again with a blank file and the first trial, the error message roughly says "invalid raster dataset, could not load..." subsequent attempts gives the more generic "could not open specified file". not sure if that's useful.
thanks for any ideas

Best Answer

  • sandyhannum
    Accepted Answer
    I wanted to post an update to this problem where I got this message with ecw or jp2 files made from GM "invalid raster dataset, could not load..." in ArcMap. I updated GM and ArcMap, same issue, dug a little deeper and found a link suggesting the aux file might be at fault (that somehow ArcMAP didn't like the pyramids already processed, go figure). I deleted just aux files associated with the jp2 and ecw files I had created, and they loaded perfectly fine. And for what it's worth Bob, it actually did determine the correct projection on the ecw file!
    thanks so much for listening, and letting me rant!


  • I found out more detail this morning. I was worried that perhaps my ArcMap installation got corrupted so tried to use the files on a different computer (this Win7 machine had ArcGIS10.3 on it). The files still would not load, but I now have more detailed errors, the ECW message "could not add.." included "the specified WKID (factory code) or WKT (definition string) is not a Projected coordinate system."  The JP2 file message was "invalid raster dataset failed to create..." but also included the "specified WKID...." message identically. So it is quite possible I exported incorrectly. I thought maybe the prj file was messed up, but it looked just like the ones that did work when exporting as a tiff. Additionally, if it matters, I don't own whatever software that natively makes ECW files. I know to esport a SID file requires you have the parent program.

  • bmg_bob
    bmg_bob Global Mapper Programmer
    I tried exporting a JP2 and ECW from Global Mapper 17.  ArcMap 10 was able to import the JP2 with no problem.  It also imported the ECW, but was unable to determine the projection (not unusual).

    What is the build date on your GM 16.2?  Are you using the most recent version? What projection is your data in?
  • sandyhannum
    edited February 2016
    thanks for your response & sorry for the delay. I had to switch gears and work on a different project last week. build date isb052915, 16.2.1. the files were TOP15-natural color county mosaics (JP2 format) in West Texas. each file was a little over a gigabyte. Our area of interest is a narrow pipeline corridor, so I was hoping to clip a portion of each county and save each chunk out to a smaller file. One of the chunks as a TIF was over 800meg, the whole county was 1 gig, the same chunk saved as JP2 was 278meg, and ECW about 350meg. the projection:  NAD83_UTM_zone_14N.  Do you think my first step should be to update GM and see how that goes? Can I ftp you a JP2 and see if you have trouble placing it in ArcMap?

  • Have just finished installing the latest update to GM version16, and re ran one of the clips, still won't open in my ArcMap, same error message as before. Is it possible I have changed some setting in my export? zis there a good way to let you see that information, to see if you can spot some mistake that I can't see? I'm also starting to wonder if my ArcMap might need to be reinstalled...yuk.
Sign In or Register to comment.