Tiled GeoTIFF Export Results in Gaps

I am using Global Mapper to re-project and re-tile some 4-band GeoTIFF orthoimagery. To do this, I am using the following procedure:

1) Create new map catalog of my original GeoTIFFs.
2) Load this .gmc and my tiling scheme into Global Mapper.
3) Tools > Configure > Projection > change to Rhode Island State Plane Feet.
4)  Make the data catalog unselectable, then select all grid tiles.
5) File > Export > Raster > GeoTIFF using the following preferences: "GeoTIFF Options" tab - uncheck box make background pixels transparent; "Tiling" tab - select use selected area feature(s) for tiles, set tile overlap to 5 pixels. Click OK, select ID for tile name field, click YES to crop exactly along tile boundaries. Choose export directory and naming prefix.

Once this process completes, I bring my rasters into a mosaic dataset in ArcMap. At the full extent you can't really tell there is an issue, but as you zoom in, you begin to see slight gaps directly along the tile clip boundaries. I'm wondering why this is happening. I've increased my tile overlap from 1 to 5 pixels and still saw the same issue. Am I missing a critical export option on one of the 3 tabs?

I don't see this issue in Global Mapper when I view all my tiles, but realistically this shouldn't matter at all. A clip shouldn't result in a gap.


  • bmg_bobbmg_bob Global Mapper Programmer Posts: 2,146
    What version of Global Mapper are you using?  If you are using version 16 or 17, I recommend getting the latest release of Global Mapper to see if the problem has already been fixed. If the problem persists in the latest release, then your best bet is to send an e-mail describing your workflow and the results (error message, etc.), with a copy of your data, to Blue Marble Geographics support (geohelp@bluemarblegeo.com). This will ensure that the support team sees the problem and can provide a timely response. Thank you.
  • edceredcer Posts: 4
    I've been doing this in version 16.1, but we've recently upgraded to the version 17 license. I'm going to update and try this again. If the problem persists, I will do as you've suggested and email support.

  • edcer said:
    click YES to crop exactly along tile boundaries. 
    The very last open, click YES to crop exactly along tile boundaries is causing the extra border around the images.
    Please try: No- crop to rectangular bounding box of each area. 
  • edceredcer Posts: 4
    I've tried re-running this procedure with your suggestion of clicking "NO - crop to rectangular bounding box of each area" and I am now getting this error for almost all of my files during export. I tried searching the forum, but was unable to find another post like this.

    Error writing GeoTIFF file A:\Imagery\NOAA_NGS_2014\GeoTIFF_RISPF_5px_NoCrop\ngs0300000200.tif
    Error trying to read strip 4000 from file A:\Imagery\NOAA_NGS_2014\UTM\2014_284200e_4561200n_orthomosaic.tif.
    Is this a network file that the connection was lost to?
    4000: Strip out of range, max 4000
    TIFFOverlay.cpp - 878
    Version: v17.0.3 (64-bit)
    Build Time: Nov 16 2015 15:11:52
    Windows 7 Ultimate (64-bit) Memory: 28,602,216,448 of 34,294,562,816 available, GDI Usage: 280 GDI (Peak 429), 119 User (Peak 295)

    I'm not quite sure what this means / what to do next. Any help would be much appreciated. I rebuilt my .gmc and that did not help.

  • edceredcer Posts: 4
    Update - this still occurs even with the Dec 22 build downloaded and installed. I re-downloaded the original GeoTIFFs, rebuilt my map catalog and attempted to export GeoTIFFs and received the same error.

    All files are stored locally on my machine and no work is being done over a network connection. All files load perfectly into both GM and ArcMap. Not every raster throws the error (above) during export, but about 1/3 do. When I ignore it and bring them into ArcMap, at least 3/4 of each image is missing.

    Would love a solution to this as it only occurs when I switch my procedure step 5 from YES to crop exactly along tile boundaries to NO crop to rectangular bounding box of each area.
  • This has been fixed in the latest daily build of Global Mapper for December 28 2015. Please contact us at geohelp@bluemarblegeo.com if you need further support
  • I know when I sometimes am recutting imagery to a new projection/grid I have to go into Configuration > General tab > Under Miscellaneous Advanced Options you have to check Export: Snap Export Bounds to Pixel Boundary if Possible

    Then when exporting, under the tiling tab, you tile based on selected features, select NO crop to rectangular bounding box of each area an under the Export Bounds tab, select All Loaded Data instead of Crop to Selected Features.  That solved my problem.

    The results you get should cover all of the area they are supposed to but it will provide a little overlap between tiles so you won't see gaps.  This may not be what you are looking for.
  • 1.Check the bounds of the crop box must round of value-like this

    Bounds: (266250.000, 7350070.000, 267250.000, 7351070.000)

    Not like that-

    Bounds: (266250.950, 7350073.210, 267251.000, 7351071.800)

    2.convertion of projection may affect the value of the bounds
Sign In or Register to comment.