Global Mapper Pro

Can't Attach Name to Area?

Roger Edrinn
Roger Edrinn Global Mapper UserTrusted User
edited February 2008 in Vector Data
Attached is a small shapefile with areas, its unusual in that it doesn't have a DBF file in the zip. No matter, it opens fine and all the data I want is their when I view it in GM.

Problem:
I view the layer in layer manager and open options and the dialog excludes attaching one of the columns to the feature name, why? I actually want to use the new concatenation tool in the dialog to have a name and number for the feature name.

What an I missing?

Thanks

Comments

  • global_mapper
    global_mapper Administrator
    edited February 2008
    If there are no attributes attached to any of the features in a file then the option to select the attribute to use for the feature name is not available. All attributes for Shapefiles are stored in the DBF, so if you have no DBF, you have no attributes to choose from for labeling.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Roger Edrinn
    Roger Edrinn Global Mapper User Trusted User
    edited February 2008
    All attributes for Shapefiles are stored in the DBF
    Clearly NOT, if you open the zip, all the attributes are there.

    I simply want to attach one column to the Feature name so I can see it relative to the area and print it for reference.

    Must be a way.

    Thanks
  • global_mapper
    global_mapper Administrator
    edited February 2008
    I took a look and there IS a DBF file in the zip file (I could of sworn there wasn't one there when I checked a minute ago). When I load the file I do get lots of attributes and the ability to select label attributes is there. Is it possible you have an older build than the latest? There were a few builds with bugs that prevented the attribute-based labeling from working. Try getting the latest from http://www.globalmapper.com/global_mapper9.zip and see if that works.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Roger Edrinn
    Roger Edrinn Global Mapper User Trusted User
    edited February 2008
    I downloaded the zip again thinking I had a corrupt D/L. Didn't help, but the new build solved the problem.

    One minor niggle, when I tried to use the multi-attribute feature, below are four separator options + custom. I tried "new line" and got a square symbol between the attributes, both on one line. I was expecting one on top the other, centered or left justified.

    Thanks for the prompt help.
  • global_mapper
    global_mapper Administrator
    edited February 2008
    The newline option is really only for point features as multi-line text for line and area objects is not yet supported. For those features you'll just get the box which is for non-printable characters.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.