'User Created Features' layer - feature counts are incorrect or missing

JakeJake Global Mapper UserPosts: 269Trusted User
edited April 2013 in Bug Report
GM 14.1 (b032113) [64 bit] Windows 7

This bug has been around for awhile now (V13 and V14) but it is starting to get too difficult to ignore.

I have a GMW with a few features on the 'User Created Features' (UCF) layer. However the 'Overlay Control Centre' says,

User Created Features [0 features, 1 deleted]

I can digitize a line and add it to the default layer (UCF). However, the counts never change. Turning off the layer causes the features to disappear so I know they are on that layer. I have saved and reopened the GMW and still no change.

Is there a way I can poke around inside the GMW file to see what is going on? The GMW is too large to email.

The GMW has about 30 layers and they all seem to be working normally except the UCF layer. Also, I can't query the Metadata for the UCF. That would be helpful so I can see the Area Count, Line Count, Line Vertex Count and Point Count.

Comments

  • JakeJake Global Mapper User Posts: 269Trusted User
    edited April 2013
    I have been trying to replicate this bug in a test file without success. It seems to be with one particular GMW. In the GMW with the problem I did a lot of manipulation and moving of features between layers. I also had some layers in different projections. Whether that caused the feature to get orphaned or not I do not know. I will try to create another scratch layer and move all the feature to the scratch layer and back again to see if that fixes the problem.

    It is also possible that at some point that I renamed the UCF. Currently it is 'User Created Features'.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited April 2013
    Actually I just saw the same bug and fixed it a few weeks back. The issue is that the UCF "layer" may actually represent multiple layers underneath if you have UCF features in different projections. This is where the bug came in as the reported feature count was only for one of the UCF layers and not all of them. If you get the latest build this should be fixed. I have placed a new build at http://www.bluemarblegeo.com/downloads/global-mapper/global_mapper14.zip with the latest changes for you to try. Simply download that file and extract the contents into your existing v14.xx installation folder to give it a try. If you are using the 64-bit v14 version there is a new build at http://www.bluemarblegeo.com/downloads/global-mapper/global_mapper14_64bit.zip .

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    Blue Marble Geographics for Coordinate Conversion, Image Reprojection and Vector Translation
  • JakeJake Global Mapper User Posts: 269Trusted User
    edited April 2013
    Thanks Mike. My first reflex is usually to get the latest build. In this case I thought the one from a month ago was sufficient. I was wrong. :) I will download the new build and see how it goes.
  • JakeJake Global Mapper User Posts: 269Trusted User
    edited April 2013
    Yes that fixed it. Thanks again Mike.
Sign In or Register to comment.