esri file gdb error

benkerrbenkerr Global Mapper UserPosts: 3
edited April 2013 in Technical Support
I've seen some reference to inability to handle non-standard projections. Is this possibly what is happening here or is there some other kind of problem? Projection is EPSG:3005.


Unable to load overlay gdb
Error opening table \LRDW_hydrometric_watersheds_20121025.
Invalid function arguments.
ESRIFileGDBOverlay.cpp - 1015
Version: v14.0.3 (64-bit)
Build Time: Oct 25 2012 13:40:43

any suggestions would be greatly appreciated!

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited April 2013
    The free Esri library for working with file geodatabases is very limited in terms of what GDBs it can load. If you have an Esri license on your machine, you can use the 32-bit version of Global Mapper v14 and load any of them as the 32-bit GM can use the full Esri licensed libraries which have no such limitations. As Esri has not yet joined the 21st century and added 64-bit support this is not in the 64-bit version.

    You can download and install the latest 32-bit release from http://www.bluemarblegeo.com/products/global-mapper-download.php . It will automatically find and use the same license.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • benkerrbenkerr Global Mapper User Posts: 3
    edited April 2013
    Nope - don't have any esri licenses, hence my problem! I can probably get access to a 9.3 license but I don't imagine that would help in accessing a v10 database though...
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited April 2013
    Actually that might work, I think that would enable the use of the Esri libraries that we use which support the later GDB versions. However I'm not 100% sure about that actually. Is it very hard for you to put Global Mapper on a machine with that type of Esri license and see if it works?

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • tjhbtjhb Global Mapper User Posts: 454Trusted User
    edited April 2013
    Is an installation of (32-bit) ArcGIS Explorer, which is free, enough to supply GM (32-bit) with the latest ESRI binaries?

    (I was under the impression that it is.)
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited April 2013
    That won't supply the license, but it might supply the libraries.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • tjhbtjhb Global Mapper User Posts: 454Trusted User
    edited April 2013
    A very tactful answer.
Sign In or Register to comment.