Problem with french letters from OSM data

falqnfalqn Global Mapper UserPosts: 123Trusted User
edited February 2013 in Vector Data
GM is opening OSM data changing some of french letters for example: à=a, è=e, ê=e, ï=i.
I have attached sample OSM data wchich includes street named "Rue de la Bibliothèque".
In OSM data: Rue de la Bibliothèque, opened in GM: Rue de la Bibliotheque - the letter è was changed in to e.
Exported data (SHP, DXF) is also incorrect - without letter è.
Is any way to solve this problem?

Best regards
Wojtek from Poland

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited January 2013
    Wojtek,

    What version of GM do you have? When I load that file I see the accented characters in the name and on the map. I'm using v14.1, but I also tested v13.2 and it worked fine as well.

    Also what are your settings for the default font character set and face name on the Vector Display tab of the Configuration dialog? I've got Times New Roman and ANSI.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • falqnfalqn Global Mapper User Posts: 123Trusted User
    edited January 2013
    Mike,
    I'm using v14.1 and I have the same default font character set and face name as you have. Probably we know where is the problem.
    Our operating system (Windows) is set to Polish language and Polish regional settings (Central Europe). When we have changed these settings to West Europe, OSM data opens correctly...
    We also find out that we can open data in West European settings, than save GMP file, go back to Polish settings and then data is OK (characters are not correct - they are represented by strange symbols), but we HAVE information about each specific character. For now it's the only way for us.
    Maybe in future will be possible to modify GM to avoid this issue?

    Best regards
    Wojtek from Poland
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited January 2013
    Wojtek,

    Yes we eventually need to make Global Mapper work directly in Unicode, then different character encodings could be supported simultaneously. Right now only one character set at a time is supported.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • Martin555Martin555 Global Mapper User Posts: 1
    edited February 2013
    Well i am also facing this problem.

    _________
    Martin55
Sign In or Register to comment.