Global Mapper Pro

Struggling with DEM, Elevations, and Shapefile

TomC
TomC Global Mapper User
edited February 2013 in Elevation Data
Howdy,

I have a DEM in GeoTIFF format that displays reasonable elevation data throughout. I wish to lay some points from a 2D shapefile on top of it and extract the z-values at those points as another shapefile. Right now, I am using Export Vector Format > Shapefile and selecting "Generate 3D features from loaded elevation data." It is providing erroneous data in the Elevation field of the new shapefile. Whereas the DEM shows elevations of 12 or 13 meters, I see values of between 200 and 1500 with some values of just 0. These data do not appear to be coming from the DEM. Any ideas? Thanks in advance.

Tom

Comments

  • global_mapper
    global_mapper Administrator
    edited December 2012
    Tom,

    Does the Shapefile perhaps already have some elevation values from somewhere? The DEM values would only be used to fill in elevations for features that don't already have an explicit elevation. If you want to override even those, you can select all of the Shapefile features with the Digitizer Tool, then right-click and select the option under the Attribute Functions submenu to add elevations from the loaded terrain. This should forcefully apply elevations from any loaded DEM layer.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
  • TomC
    TomC Global Mapper User
    edited December 2012
    Hola Mike,

    Thank you for the reply. No, the original shapefile does not have any elevation values in it. I created it from an xy table using ArcCatalog. However, your digitizer trick worked nicely for filling in the values. Thank you for that.
  • MikeG
    MikeG Global Mapper User
    edited February 2013
    Mike,

    I have a surface elevation contours in one projection that I converted to a TEG and an underlying formation contours that I converted to a TEG. The underlying formation has a projection which is in meter in the x and y, but feet in Z. When I create the TEG the Z feet value is multiplied by 3.28 and 60 feet becomes 196.85. How do I correct for this?

    Thanks,

    MikeG
  • global_mapper
    global_mapper Administrator
    edited February 2013
    Mike,

    Global Mapper supports different horizontal and vertical units. Just go to the Alter Elevations tab of the Options dialog for the grid layer and set the elevation units to whatever is correct for the layer. Then any conversions of elevation units should proceed correctly.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com/
Sign In or Register to comment.