Custom feature types question

tdaltontdalton Global Mapper UserPosts: 7
edited September 2012 in Technical Support
Hello,

I created quite a few vector area types deliniating different types of habitat using the following process. Configure -> Area Styles -> New Type

Each of the new types has its own unique attributes.

Is there a way to export these area types (with their attributes) so that my colleague can use them on her machine as she digitizes the same raster data? I tried right clicking on the Area Types and Saving to file, but when she opened the file it displayed "Zero types disabled" and did not display any of the custom area types.

Currently when she opens my .gmw files none of my vector areas display and she is only able to view the raster data.

We are both using GM version 13.2 64bit

Thanks in advance!

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2012
    Did you save your type list from the Area Styles tab of the Configuration dialog or from the type filter dialog? It sounds almost like you saved a filter file and not a style file. To get your custom types you would want to right-click on the area type list on the Area Styles tab and save the .gm_style file from there, then open that on her machine.

    You might also consider using Global Mapper Package files as they contain all of the actual data and types so are completely portable. You can export those under the File->Export menu.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • tdaltontdalton Global Mapper User Posts: 7
    edited September 2012
    Hi Mike,

    Thanks for your (as usual!) rapid reply. I saved a .gm_style file as you advised and then opened it on her machine. The feature types were added to her list of area features, and the styles (border color and fill) are correct, but all of the attribute data is missing. Are the attributes transferrable?

    I also noticed that when I open one of my .gmw files on her machine, all of mycustom feature types display with the correct attribute data, but when I try to create new area features (from my custom types) none of the attribute data is present. We could just enter the attributes for each custom feature type on her machine, but are trying to avoid that since it was rather time consuming. What would you advise we do?


    Thank you!
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2012
    The default attribute list for each type is stored in a .txt file in the user data folder. However, if you have v14 I decided to go ahead and update that to save the default attribute lists for each type in the .gm_style file as well so you can easily transfer that as well. I have placed a new build at http://www.globalmapper.com/global_mapper14.zip with the change for you to try. Simply download that file and extract the contents into your existing v14.xx installation folder to give it a try. If you are using the 64-bit v14 version there is a new build at http://www.globalmapper.com/global_mapper14_64bit.zip .

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • tdaltontdalton Global Mapper User Posts: 7
    edited September 2012
    Thanks a lot Mike!
Sign In or Register to comment.