Display affected by imported terrain data

NorthSouthNorthSouth Global Mapper UserPosts: 21Trusted User
edited September 2012 in Technical Support
I recently imported a couple of square kilometres worth of higher resolution data - as an xyz file - to a workspace based on 1.5 arcsecond terrain data. Initially when I did that the added 2 sq km displayed as flat grey areas with no topography. The rest of the workspace continued to show the terrain contours normally, and when I ran line of sight calculations across the 2 sq km it was clearly using the imported data. But why does it display as flat grey and not shaded contours like the rest?

Now, since saving the workspace, when I open it the entire workspace shows as flat grey, although the underlying terrain data is definitely there. Playing about with switching on/off the different layers makes no difference.

Any ideas?

NS

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2012
    Do you perhaps have a custom layer shader setup for one of the layers? This is on the Options dialog for the layer. Also what shared shader do you have selected on the toolbar? This would affect the coloring.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • NorthSouthNorthSouth Global Mapper User Posts: 21Trusted User
    edited September 2012
    The base layer has 'Default Shared Shader' selected when I click on options for that layer. When I click on Options for the imported layer, it produces only a dialog box for 'Vector Options', not Elevation Options, so there seems to be no option for selecting a shader.

    The default shader on the toolbar is Atlas Shader.

    When I load the workspace, you can see it loading the base layer with coloured terrain first, then it covers the whole thing in grey.

    NS
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2012
    How are you loading the XYZ file? It sounds like it is coming in as vector point data and not being gridded into a terrain layer. When you load the XYZ file specify to create an elevation grid from it rather than loading as Point Only to get an elevation grid that a shader would apply to.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • NorthSouthNorthSouth Global Mapper User Posts: 21Trusted User
    edited September 2012
    Thanks Mike, now sorted I think. I had set the Grid Spacing to 100m so when loading a layer at the initial scale, it was loading all the terrain data properly but then covering the whole thing in lots of grey lines which obscured the terrain data underneath. Beginner's rudimentary error!
    NS
Sign In or Register to comment.