Edge effects in multiple elevation grid layers

OseiOsei Global Mapper UserPosts: 119Trusted User
edited September 2012 in SDK
We are using SDK13.1 though this problem can also be reproduced in the Global Mapper application itself. We have come up with this issue. I have two grid layers (please find attached el1.txt and el2.txt).
I load both layers into GM. In the properties for el1.txt, I set the shader to a custom shader (please find attached el1 shader.clr). I set the Global Shader to Atlas.
What one will see is edge effects in el2 when both layers are turned on. If layer el1 is turned off, the edge effects disappear (see img-edge.jpg and img-noedge.jpg attached).
I believe this is due to interpolation of values in el2 with el1 at the edges. Is there a way by which we can turn off this edge effect.

GM_RasterDisplayOptions_t used to have a mInterpolatePixels flag but that seems to be obsolete in the current SDK.

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2012
    Can you save a workspace file where you are seeing the edge effect? I just tried in 14.0 and don't see any edge blending like you are seeing.

    The mInterpolatePixels flag was replaced a while again with the mSamplingMethod value to allow more types of resampling. It is backwards compatible in code in that 0 is still no sampling and 1 is bilinear interpolation which is how the mInterpolatePixels flag worked. There are just additional values available now.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • OseiOsei Global Mapper User Posts: 119Trusted User
    edited September 2012
    I am adding a GM workspace file. You may need to open it and modify the file locations.

    On opening the workspace, you will notice the top layer seems not to have straight edges. If el1.xyz is turned off it still seems not straight forward. If you force a redraw by zooming in and out (with el1.xyz still off), then the edges rectify and you have straight edges all round.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2012
    Which version are you using? I don't see the non-linear edges in either v13.2 or v14.0.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • OseiOsei Global Mapper User Posts: 119Trusted User
    edited September 2012
    I have sent a video of the edge effect to your email since it is quite large and you may want to delete it after viewing. It tries to demonstrate the edge effect.
Sign In or Register to comment.