Global Mapper Pro

Map Catalog only exporting transparent images

jdh5259
jdh5259 Global Mapper UserTrusted User
edited August 2012 in Raster Data
I was wondering if someone could help me understand why exporting my map catalog results with every image being transparent.

I just started using the map catalog because I ran into some pretty heavy performance hits and everywhere I looked on these forums suggested using the catalog to improve performance of exports. I am currently exporting KML super overlay raster of vector data using v13.2 (b072312). I use a script in order to perform multiple exports one after the other. The script works fine if I import all of the data directly instead of using the catalog.

I have played around with the "When to Display Maps" options for the map catalog but nothing I change seems to help. I figured if anything would work the "Always Show Map if in View" option would but I still end up with every image being transparent.

During the export, the process of events goes something like: some data will load in, one or more images will export, more data will load in, etc. until the entire export is finished. This makes me think that the catalog is doing its job of only loading in the necessary data but why then are all of my images transparent?

Any help would be greatly appreciated. Thanks in advance.

Comments

  • global_mapper
    global_mapper Administrator
    edited August 2012
    Can you provide your script so I can see if it is setup right? It does indeed sound like the maps aren't rendering. What type of data does your map catalog contain? If you load the map catalog in the user interface and export from there rather than the script does that work?

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • jdh5259
    jdh5259 Global Mapper User Trusted User
    edited August 2012
    The catalog only contains DNC data (VPF). I tried running the catalog export both from the GUI and from the script using two catalogs for each: one with the default "Map Box is % of Display Size" and one with "Always Show Map if in View". Both catalogs seemed to work fine when exported from the GUI but both of the script exports contained all transparent images.

    My script used for these exports:

    GLOBAL_MAPPER_SCRIPT VERSION=1.00
    SET_LOG_FILE FILENAME="C:\DNC\test.log"

    UNLOAD_ALL

    IMPORT FILENAME="C:\DNC\test.gmc" LOAD_FLAGS="COVERAGES=''*''"

    LOAD_TYPE_FILTER FILENAME="c:\DNC\filters\point_level_0.gmf" FILTER_TYPE=POINT
    LOAD_TYPE_FILTER FILENAME="c:\DNC\filters\line_level_0.gmf" FILTER_TYPE=LINE

    EXPORT_RASTER FILENAME="C:\DNC\test.kml" TYPE=KML KML_RASTER_FORMAT=PNG \
    KML_SUPER_OVERLAY=YES KML_TILE_SIZE=512 SPATIAL_RES_METERS="100,100" LAT_LON_BOUNDS="-86.1356,24.0498,-79.5683,30.5491" GRID_CREATE_FOLDERS=YES

    Where the LOAD_FLAGS uses the two single quotes for the ''*'' and the filters only have a couple things deselected from each. The filters work fine with the other exports. I played around with the SPATIAL_RES_METERS a bit but still got transparent images.

    Thanks for the help.
  • global_mapper
    global_mapper Administrator
    edited August 2012
    Try adding INC_VECTOR_DATA=YES to your EXPORT_RASTER command. As it is now it doesn't look like the vector data would be saved, so you would end up with empty tiles.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • jdh5259
    jdh5259 Global Mapper User Trusted User
    edited August 2012
    Thanks! Appears to be working fine now. It is interesting that I never had to use that flag before and still got data to appear in my exports.

    I appreciate the quick response. Thanks again.
  • global_mapper
    global_mapper Administrator
    edited August 2012
    There are some smarts with the flag such that if all that you have open is vector data it is set by default. Map catalogs are a bit weird though in that they can contain both raster and vector data, so the presence of a map catalog looks like raster so the INC_VECTOR_DATA flag isn't set by default if a map catalog is loaded.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • jdh5259
    jdh5259 Global Mapper User Trusted User
    edited August 2012
    Makes sense. Thanks for clarifying.

    Quick question to go along with this: Is there any way of creating the map catalog file via the script? I didn't find any reference to the catalog in the scripting guide in any section other than the IMPORT command so I am assuming that this is not currently possible.

    Thanks for all of the help.
  • global_mapper
    global_mapper Administrator
    edited August 2012
    That is correct, you cannot currently create one via script. You can do it with the SDK if you want via several GM_MapCatalog* functions. See the Developers page at http://www.globalmapper.com for details.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
Sign In or Register to comment.