Problems with GM_LoadLayerList and VMAP data

Eylon ShacharEylon Shachar Global Mapper UserPosts: 2
edited February 2012 in SDK
Hi

We are using Global Mapper SDK (version 12) to convert GIS data in standard formats to our system run-time format.
The conversion process is automatic, whenever the user copy new files they are automatically converted.
In order to load the data we are using GM_LoadLayerList function.

The problem is that when we are loading data in VMAP format the function opens a dialog window where the user is asked to choose the type of data he wants to load, by default all the available types are marked.
Since it is an automatic process there is no one to press O.K and the process stops.
In the aLoadFlags parameter of the function I tried to put GM_LoadFlags_HideAllPrompts but it didn’t help.

Is there a solution for that?

Thanks

Eylon


prompt.PNG

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited February 2012
    Eylon,

    Yes, what you can do is use GM_LoadLayerListEx instead and in the aExtraLoadOptions string parameter pass "COVERAGES=\"*\"". This will say that you want to use all coverages and it won't show the prompt. If you want to filter the coverages automatically provide a comma-delimited list of coverages to use.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Eylon ShacharEylon Shachar Global Mapper User Posts: 2
    edited February 2012
    It works
    Thanks
    Eylon,

    Yes, what you can do is use GM_LoadLayerListEx instead and in the aExtraLoadOptions string parameter pass "COVERAGES=\"*\"". This will say that you want to use all coverages and it won't show the prompt. If you want to filter the coverages automatically provide a comma-delimited list of coverages to use.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
Sign In or Register to comment.