Global Mapper Pro

Zoom to view in Google Earth

Ice Age Mark
Ice Age Mark Global Mapper UserTrusted User
edited April 2012 in Suggestion Box
Howdy Mike,

Happy New Year to you.

Back when you gave V12 users early use of "Zoom to view in Google Earth", there were issues with Windows 7/64 bit users because GE is 32 bit. This seems to be the case again (at least for me) as it only opens GE, and nothing else. Any chance you could cobble together the partial fix that you did for V12?

Thank you sir,

Mark

[V13 B122811]

Comments

  • global_mapper
    global_mapper Administrator
    edited January 2012
    Mark,

    Any fix done in V12 in also in v13. I think in those case you have to use the 'View in Google Earth' twice, once to open it up, and then the second time the bounds actually get set.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Ice Age Mark
    Ice Age Mark Global Mapper User Trusted User
    edited January 2012
    Mike,

    Thanks for responding so quickly. I guess that makes it a problem with my system, since no one else has had this happen. Any ideas what else could go wrong. I've tried "opening it twice" (I think, but I'm not totally clear what that means), but to no avail. One thing I noticed when using V12 was that when I closed GE it asked me about saving the KML(Z?) file that was created in order to zoom (a bounding box, I'm guessing), and this is not happening now. I have the latest update of GE. Another thing I "think" I remember from V12 was that GE opened but didn't zoom if no raster imagery was loaded (like just a DEM with vector data), so I've tried both ways. I know user error and computer idiosyncrasies are beyond your control, but I don't know what else to try. I sure do want to use this feature.

    Thanks regardless, no hurry.

    Mark
  • global_mapper
    global_mapper Administrator
    edited January 2012
    Mark,

    It is strange and doesn't seem to be a 64-bit issue. When I run 64-bit Global Mapper v13 the zoom to Google Earth option works fine, I don't even have to do it twice if Google Earth wasn't already open. What is different is that with the 64-bit version I can't connect to the Google Earth COM server to direct it to zoom to the specified location, so GM has to create a KML file with the bounds, then open that with the Windows shell, which in effect should open it with Google Earth assuming GE is associated with KML files. That is why you see a new KML layer in GE when opened with 64-bit GM. I'm not sure of a good way around this, but it does work fine for me, you just have to specify not to save any changes. If you run the 32-bit GM on that same computer does it work fine?

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Ice Age Mark
    Ice Age Mark Global Mapper User Trusted User
    edited January 2012
    Mike,

    I tried the 32bit version of GM 13.01, and the "zoom to view in GE" works perfectly, and is VERY fast as well. No luck with the 64bit version. I can just use GM 32bit instead, as I have no size, speed, or processing time issues with the things I do. I just always use GM 64bit because I have a 64 bit computer. I'll chock it up to another one of those computer world mysteries I don't understand. Thanks for your help, and once again, GM is a fantastic and versitile product; almost like a miracle to a person from the days of ink on mylar and trips to the blueprinter.

    Mark
  • RobertR
    RobertR GlobalMapper Fan! Trusted User
    edited April 2012
    same here. It does not work for me in 64bit;

    I am using GM for a while now and surely it is something with the installation process (the folder where it installs and so on) because I had problems with the "choose default program to open files" option (GM 64bit did not appear in the list because when it installs windows sees it's .exe path in a different location than the actual one); to solve this problem I just edited the registry with the actual path towards the .exe file and now it works;

    TO solve the Zoom to View in Google earth, I installed the 32bit and it works like a charm. (in my case, by default, GM 64bit was installed in /C:/Program Files/GlobalMapper13_64bit and GM13 on 32bit installed in /C:/Program Files (x86)/GlobalMapper13);

    I guess (again) it has something to do with the install pack.
Sign In or Register to comment.