Global Mapper Pro

Las 1.2

chrisgrandin
chrisgrandin Global Mapper UserTrusted User
edited November 2011 in Elevation Data
Hi,

Is there support for writing LAS 1.2 in GM 13? I try to write it but the header in the LAS just tells me 1.1. I can see the header using (QT Reader). The thing is I try to load it into Terra Scan with rgb values, but terrascan refuses to show the colors because it thinks it is a Las 1.1.

All the best,

Christofer

Comments

  • global_mapper
    global_mapper Administrator
    edited November 2011
    Christofer,

    You are correct, the LAS format should be 1.2 if color is included (GM doesn't care so long as the point format ID is ok, but other software might). I have fixed this since 1.2 is used in the header if you include colors. I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the change for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • chrisgrandin
    chrisgrandin Global Mapper User Trusted User
    edited November 2011
    Hi Mike,

    Thanks for the new build and the as usual fast reply and fix!

    TerraScan now recognize las files as being 1.2 format. However in Terra Scan all points have color values of R000 G000 B000 when I import them. I don't quite get it actually. If I assign colors to the points in Terra Scan and export as las 1.2, the colors will show correctly inside GM and QT Reader, if I assign colors in GM the QT-reader will show the colors correctly but not Terra Scan.

    I be happy to provide you with a las 1.2 written from Terra Scan (with color values) if that will help!

    Besides it would be nice feature to manually be able to choose which version of las GM writes files in.

    All the best,

    Christofer
  • global_mapper
    global_mapper Administrator
    edited November 2011
    Christofer,

    If you can provide a file that Terra Scan recognizes as having colors I can take a look and maybe find what it has that is different than what GM is producing that QT Reader but not Terra Scan recognizes.

    Currently GM takes the approach of writing out the lowest LAS version that can contain all of the features that you requested to have (i.e. LAS 1.2 if you use colors or add a global encoding or source ID value), but LAS 1.1 if you aren't using those. It is expected that a LAS reader than supports 1.2 should also support any earlier versions.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • chrisgrandin
    chrisgrandin Global Mapper User Trusted User
    edited November 2011
    Hi Mike,

    I have mailed you an example of a Las 1.2. Hope it helps!

    I understand the GM approach on writing las, it make sense.

    But it becomes an issue if I read an Las 1.2 that already contains colors, and export it from GM. If I do that GM writes the files as 1.1 and the colors are lost. I think a better approach would be to never go down the hill, if it is 1.2 in original it still should be 1.2 with whatever attributes it had. If it was 1.1 with no colors, and I add colors in GM it would be uprated to 1.2.

    All the best,

    Christofer
  • global_mapper
    global_mapper Administrator
    edited November 2011
    Christofer,

    Thanks for the file. I'm guessing the issue is whether the RGB values are stored in the upper or lower 8 bits of the 16-bit color values for each point. GM can handle them either way, but was exporting them in the lower 8 bits. The file that you provided used the upper 8 bits. I have updated GM to write them in the upper 8 bits so hopefully Terrascan will now work with the colors. I also updated the export of colored LAS files to allow pulling the colors from the source points if you are doing a LAS-to-LAS export.

    I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the change for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • chrisgrandin
    chrisgrandin Global Mapper User Trusted User
    edited November 2011
    Hi Mike,

    It seems to work excellent!

    Big thanks!
Sign In or Register to comment.