Global Mapper Pro Coming Soon

Fixing crosspoint errors due to overlapping shape-borders

TotoroTotoro Global Mapper UserPosts: 18
edited November 2011 in Vector Data
I have a landcover vector-map in both line and shape format. I have been trying to use the shape version of the map (they look identical when viewed in GM) but have been unable to remove the crosspoint errors which pop up in WAsP, causing the results to be completely wrong.

If I understand the problem, the lines of the shapes (roughness areas) are sometimes overlapping, causing inconsistencies between the roughness values assigned to the outside of them.

I have tried using buffers, I have tried making an elevation grid and then creating areas from similar values, splitting the map based on the roughness values...no luck. I am simply at a loss at how to proceed. Maybe I am missing a step? I am not 100% in my understanding of what the problem is and therefore not sure how to fix it. The areas are inside each other sometimes, overlapping sometimes (rarely) but mostly just sharing a border.

Should I use the line version of the map? How do I even start? What can I do to remove the overlapping lines?

When I started I thought it would be as simple as adding a roughness attribute value based on the landcover type but now there is an inside AND an outside.

I am getting desperate here. :(

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2011
    You could try exporting your colored landcover map (use different colors for each landcover type) to a raster file, like a GeoTIFF, then load that back in, right-click on it in the Control Center, then select to create equal-value areas. This will give you separate areas for each individual color (i.e. landcover type) with no overlaps. You can then assign roughness to those and export that.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • TotoroTotoro Global Mapper User Posts: 18
    edited November 2011
    Thanks for the tip, I tried it out, but since the shapes (although now jagged) still share an edge with other (jagged) shapes, there are still "crosspoints" although the shapes aren't actually crossing, only overlapping.

    I am amazed that making a simple roughness map could be this hard. I do not blame GM since the software is amazing and so is the support you give (thanks again), but I am really at a loss now.

    THE SITUATION RIGHT NOW:

    Any time I export only elevation and coastline, I have no problems. If I export only one kind of landcover shape (a certain roughness), then there are only "a few" (hundred) crosspoints and the WAsP calculations I am making are quite accurate. Whenever I increase the amount of shapes by including other roughness areas, the number of shared borders increases exponentially, and the errors are so many that the results I get are useless.

    I cannot fathom how WAsP cannot support a shape only having a value for its own inside and then applying a default value (that it could ask for) to any area not within a shape. Then it could report any inconsistencies after that. As it stands now, any single overlapping border is reported for every shared node and the result is THOUSANDS of errors, maps that take 10 minutes to load into the WAsP map editor to check errors and unusable results.

    Seems like GM, with all its options and amazing abilities, still cannot make WAsP happy. :(
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2011
    Have you tried emailing WAsP support on this? I suppose if they could respond with how and why they expect things to be it might be easier to get GM to generate that result. Or maybe they could update their software to handle the non-overlapping area case more intelligently?

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • TotoroTotoro Global Mapper User Posts: 18
    edited November 2011
    I contacted them a couple of times and at least for the time being, the answer was that the problem is the way I edit the files before using it in WAsP and then that the only way to solve it is through manual editing.

    Will keep trying. Thanks again for the help Mike, you are very easily the best and most useful forum admin I have seen on the internet. :)
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2011
    One other thing to try is to select all of the areas that adjoin but don't overlap with the Digitizer Tool, then right-click and select the option to create buffer areas, then create buffers with a small negative distance (like -1.0 meters). This should create slightly shrunken versions of all of the areas so they would no longer adjoin. You could then close the original layer and export the slightly shrunken ones to a WAsP .map file and see if that works.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • TotoroTotoro Global Mapper User Posts: 18
    edited November 2011
    This is what I have tried to do, but when I create the buffer, I actually only get the buffer-areas themselves, not a slightly smaller "buffered" area. Using an orange as an analogy, since I suck at explaining, I am left with the "peel" instead of the peeled orange.

    How do I fix this? After much testing and discussion on the WAsP side, I feel that this IS the way to go. It should work. Every time I create buffers though, I get the buffers alone, and it takes almost 2 hours to generate them... :/
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2011
    Can you maybe save a workspace file after you do this operation and zip it up then either attach it here or email it to gmsupport@bluemarblegeo.com so I can see what you are talking about?

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • TotoroTotoro Global Mapper User Posts: 18
    edited November 2011
    I actually think I have solved it but it will take an hour yet to know :T

    I was using polylines instead of polygons so a buffer on the lines of -2 meters caused -2 meter wide areas. :) Trying with shapes now and hoping that this will solve my problems.

    What I am doing is editing a landcover map into a roughness map for use in WAsP.

    Steps so far:

    1) Search for landcover codes in the attributes, and add roughness ROUGH_L and ROUGH_R values for them. The outside is set as the default value, which will fill the buffer areas I create later.
    2) Edit out lakes which were defined as coastline(?)
    3) Remember to switch this for the coastline, which has 0 for OUTSIDE the area and default for INSIDE.
    4) Select the polygon shapes and add -2 buffer.
    5) Results pending, but I am very hopeful. :)

    The problems I have been having have afaik, been a combination of landcover and coastline areas (lines/verteces) touching or being shared, or some areas having several "outside" areas. With the buffer, there will be a "default" area, which will fill the land area, having separate inside values for the different roughness values in it. There will be no crossing lines, no touching lines, no shared verteces and the "outside" values will match.

    I feel quite certain that I have the solution...still...have been battling with this problem for weeks so do not dare to hope too much.

    Still, thanks again Mike! You are the man! :)
  • TotoroTotoro Global Mapper User Posts: 18
    edited November 2011
    Ok, closer to a solution, but now I have the following problem:

    When I create buffers, there are only buffers created around areas that border other areas. Other areas have the buffer applied to them, but since there is no "corresponding" border there, there is no buffer area between the two roughness areas like there is when two of them are sharing a border.

    Example: A lake inside a forest does not "border" a forest. It is inside it, the borders of the forest are nowhere near the border of the lake, so there is no buffer area created between the forest and the lake. The only thing that happens is that the lake changes size when I create the buffer, as does the forest of course.

    What I need is a buffer-area as a separate area around ALL the shapes. I can then apply the ROUGH_L of that buffer area to ALL shapes. In fact, that kind of area is probably what I created when I used the lines and created buffers instead of using shapes (see above)...my problem now is how to successfully integrate these two parts since I cannot have overlapping areas or shared borders in wasp...

    Any thoughts?
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2011
    Assuming where you have a situation like a lake inside a forest that you also have a hole/island in the forest I think I have a solution. You need to turn your areas with islands into single connected sets of vertices rather than separate areas acting as holes/islands. To do this select the areas with the Digitizer Tool, then right-click and select the Advanced Feature Creation submenu option to create a single vertex list area from the selected areas. This will connect the islands in any areas to the parent with "stock arcs" so they become a single vertex list. You can then do the negative buffer on those and the common interior borders should also shrink away.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
Sign In or Register to comment.