Global Mapper Pro

Reprojecting PNG to TIFF - transparency issues

RobertR
RobertR GlobalMapper Fan!Trusted User
edited November 2011 in Raster Data
Hello GM Community,

I have a problem when it comes to this subject. I am loading the png file, placing 3 ground control points. I am also selecting the projection to the one I want my final TIFF to be (epsg:2263).

Everything worked out fine until I loaded my image in a web mapping tool (Chameleon); The thing is, I have a strip of color (my background from GlobalMapper) all around the image (it overlaps my surrounding tiff files).

The source PNG file is ok, I've set that strip transparent in Adobe Photoshop prior of loading it in Global Mapper;

I know that Qgis has an option to set the pixels transparent when needed (or something like this) which works for me but it renders large data very slowly so I always prefer Global Mapper; I am looking for the same thing here. I do not want that strip of color around my image. I would like it to be transparent;

I also tried to export the resulted TIFF image from GM and check a few things like "make background (void) pixels transparent" or setting the "set transparent color" to the one that corresponds to my GM background (in overlay center - options) but this failed as well in the end. That strip of color still appears and I do not know how to get rid of it.

Thanks,
Robert

Comments

  • global_mapper
    global_mapper Administrator
    edited November 2011
    Robert,

    The 'Make Background (Void) Pixels Transparent' option should work to mark any no-data pixels as transparent. If you load it back into GM is the strip invisible? It could just be that Chameleon doesn't support transparent TIFF files. They are much less commonly supported than transparent PNG files for example.

    Thanks,

    Mike
    Global Mapper Support
    gmsupport@bluemarblegeo.com
    http://www.bluemarblegeo.com
Sign In or Register to comment.