Global Mapper Pro

Automatic delete overlapping overlay

EricGagne
EricGagne Global Mapper UserTrusted User
edited October 2011 in Vector Data
Hello,

I have some difficulties with overlapping overlays.

A comes from a Garmin IMG converted to .shp
B is a .shp files created from a scan of a printed map in ARCGIS.

My problem is that the lines in the area covered by both overlays aren't aligned. I tried fixing that by shifting one of the overlays but since it comes from a printed map the lignes don't have the exact same shape and I can still see two lines most of the time.

I would like to remove everything from A in the area that is covered by B. Is there a way to that automaticlaly in GM ?
D.JPG 209.1K

Comments

  • global_mapper
    global_mapper Administrator
    edited October 2011
    What you can do is right-click on both A and B in the Control Center and select to create bounding rectangle areas from the layers, then select the layer B bounding rectangle with the Digitizer Tool, then right-click and select to subtract it from an area and choose area A. You will then have a crop area from A with a hole for B. Then select that new area, go to the Cropping tab of the Options dialog for layer A, then specify to crop to the area. That should cut out the area of B from A.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • EricGagne
    EricGagne Global Mapper User Trusted User
    edited October 2011
    Then select that new area, go to the Cropping tab of the Options dialog for layer A, then specify to crop to the area. That should cut out the area of B from A.
    support@globalmapper.com

    Mike,

    I don't understand what you mean there, I can't find any "crop" feature anywhere. I created my "island" but I'm stuck there.

    Eric
    crop.JPG 144.2K
  • EricGagne
    EricGagne Global Mapper User Trusted User
    edited October 2011
    Mike I've been searching and I think you're talking about cropping raster data but this is vector data.
  • global_mapper
    global_mapper Administrator
    edited October 2011
    Ah sorry you are right, I was thinking A was the raster for some reason. What you need to do for this case is simply make your raster layer B draw on top of the vector layer A and block it out. To do this, make sure layer B is after layer A in the Control Center, then on the Vector Display tab of the Configuration dialog set the 'Vector Layer Order During Draw' option to the 2nd setting so that layer order takes precedence over layer type and you should get what you are after.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.