File Geodatabase support in v13 - Bug Reports

ClementBClementB Global Mapper UserPosts: 16Trusted User
edited September 2011 in Bug Report
Hi there,

I didn't see any other topic focused on feedback for the brand new file geodatabase format support in version 13, so here are the first bugs I found:
  • Missing attributes in the attribute tables
    either only attributes whose type is String are displayed, or Integer /Double fields are missing I am not quite sure which one it is.
  • Arcs support missing (example: output from the ArcGIS's Buffer tool)
    File geodatabase supports arcs in polylines / polygons. If Global mapper can't support them natively could you make it to interpolate the arcs so that curves stay curved?
  • Import selected feature class would be great
    I already mentionned that before and I know it is already on your task list but I am writing it again just to group things together: I think having an intermediate menu asking the user which feature classes he wants to load would be beneficial instead of loading the whole thing.

I know ESRI's file geodatabase API has a lot of shortcomings, so you may not be able to fix those problems but at least they are now logged!

Thanks for adding that feature to GM, it is already really helpful and I'm sure it will get better with time.

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    Do you have any sample GDB files that are missing attributes and arcs? I think I should be able to get those issues fixed at least. I should be able to add an option to select which feature classes to load as well.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    I went ahead and added a prompt to select which feature classes to select when loading an ESRI FGDB. I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the change for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    I went ahead and added a prompt to select which feature classes to select when loading an ESRI FGDB. I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the change for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • ClementBClementB Global Mapper User Posts: 16Trusted User
    edited September 2011
    Thanks Mike!

    I just tried your new build, the new menu will be great for people working in companies like mine where file gdbs can grow a lot.

    I also prepared a test gdb for you, you'll find it attached. On that really simple example there is a point feature class with attributes of various types. Only the "text" attribute is shown in GM. Those points have also been buffered, and GM fails to display the resulting arcs and circles.

    globalMapperTestCase.gdb.zip
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    I have updated the import to support non-string attribute values. I'm still working on the curves. I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the change for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • paulp575paulp575 Global Mapper User Posts: 59Trusted User
    edited September 2011
    Not sure this is the place to report this so if it's not, please more it to the correct thread.

    I just purchased v13 and tried to open several GDB files from the USFS. On all of them, I keep getting the following error (I've also attached a copy of the screen shot of the error message):

    Unable to load overlay gdb
    This release of the GeoDatabase is either invalid or out of date.
    The ESRI File Geodatabase library does not support GDB files from ArcGIS v9.x or earlier. You will need to convert your GDB data set to a newer version using ArcGIS v10.x or later to make it readable.
    ESRIFileGDBOverlay.cpp - 641
    Version: v13.00
    Build Time: Sep 12 2011 23:24:43

    Is this a GM13 error message or is there a problem with the GDB file?

    Can't attach the file giving me this error as it's around 4.5 MB in size!
    You can download the file from here: http://www.fs.fed.us/r6/data-library/gis/colville/
  • tjhbtjhb Global Mapper User Posts: 454Trusted User
    edited September 2011
    The error message is right. The problem is what it says.

    There is no public API for GDB formats before version 10, so nobody (not even Mike) can support them directly. (Some products support them indirectly, by relying on the existence of an ESRI licence and ESRI dlls on the system.)
  • tjhbtjhb Global Mapper User Posts: 454Trusted User
    edited September 2011
    Mike maybe it would save grief to add the limitation to the release notes?

    I know it's an ESRI thing (which they barely mention), not a GM thing, but users won't necessarily know that.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    I went ahead and updated the release notes on the web site to indicate GDB files from ArcGIS v10 and later to hopefully avoid some confusion, although I doubt many people read those.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    I have updated the GDB importer to support the types of arcs in the file that you provided. There are some other types too, but until I can get a sample I can't add support for those types. I have placed a new build at http://www.globalmapper.com/global_mapper13.zip with the change for you to try. Simply download that file and extract the contents into your existing v13.xx installation folder to give it a try. If you are using the 64-bit v13 version there is a new build at http://www.globalmapper.com/global_mapper13_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • ClementBClementB Global Mapper User Posts: 16Trusted User
    edited September 2011
    Hi Mike,

    I just gave it a go and it works great on the example I sent.

    Thanks a lot for your hard work!
  • paulp575paulp575 Global Mapper User Posts: 59Trusted User
    edited September 2011
    tjhb wrote: »
    The error message is right. The problem is what it says.

    There is no public API for GDB formats before version 10, so nobody (not even Mike) can support them directly. (Some products support them indirectly, by relying on the existence of an ESRI licence and ESRI dlls on the system.)

    I know this is a GM forum, but does anyone know if the ESRI ArcGIS Explorer will read these files?
    I'm hoping to open these files in that program as many government entities are moving their files from ESRI shapefiles to the GDB format.
Sign In or Register to comment.