Unexpected colors for bathymetry shading

LelandLeland Global Mapper UserPosts: 8
edited September 2011 in Bug Report
When defining a custom shader that includes colors for elevations below sea level, the colors that show up on the map don't match these shader colors.

Steps to see the problem using the attached files:

1. Load the file test_sea.flt. It contains elevation values that range linearly from about +1000m at the north edge to -2500m at the south edge. Disable hill shading.

2. Click "Add Custom Shader" from the drop-down list, and load the Surfer CLR file "undersea.clr". Before closing the "Custom Shader" window, notice the colors assigned to negative elevation values (yellow/orange/green).

3. Click OK, and notice the map colors. Positive elevations have the expected colors, but negative elevations have purples and blues that don't resemble the shader colors at all.

It looks to me like the colors defined in the shader are being blended with some shade of blue for all negative elevations. Maybe this is an intentional feature - perhaps I haven't read the documentation carefully enough. But if so, is there a way to turn this off so that I can select colors in the shader window according to how they'll look on the map?

Note that I suspect this change would also affect the way the built-in shaders look for negative elevations, which may not be desirable.

-- Leland

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2011
    Leland,

    Check the Vertical Options tab of the Configuration dialog. You likely have water display enabled, so your colors are indeed blending with blue.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • LelandLeland Global Mapper User Posts: 8
    edited September 2011
    Ah, yes, that's what I was looking for. I thought maybe I had seen that somewhere, but I couldn't find it again. Thanks for the help!

    -- Leland
Sign In or Register to comment.