Export GeoTIFF 4GB limit

STHSTH Global Mapper UserPosts: 434Trusted User
edited January 2008 in Bug Report
Loading:
- Several GeoTIFFs
- 1 shape file describing the "cut-out" areas

Export all raster- data within "cut-out" areas - outside set to background color.

When selecting all areas and trying to export I only get the "4GB size limit". However selecting half of them, and export. And then the other half and export, it is possible to export. (The filesize of the files are then 65MB + 100MB).

I believe that the 4GB- size error message counts the file as being filled with data - and does not consider the fact that 90% of the image is background colored and will compress very well. Is there some way to change this so I can export all areas into one file? Or is this message related to another fact that GeoTIFF- files can only have a limited number of tiles - and this limit is exceeded when working over large areas?

Another way to do it is to export each single area within the shape-file to a new GeoTIFF-file, however I have to select them manually or write a script to do this.

UPDATE: Seems I have a double post, tried to delete the previous one, but could figure out how to do it :(

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited January 2008
    I took a look and discovered that the 4GB test was being issued even is LZW compression was used. I have placed a new build at http://www.globalmapper.com/global_mapper9.zip with this changed for you to try. Simply download that file and extract the contents into your existing v9.xx installation folder to give it a try.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • STHSTH Global Mapper User Posts: 434Trusted User
    edited January 2008
    I set the settings to LZW-compress and I get a message: Amount of data may be too large - Would you like to continue?" and answer: YES. Then it tries to find optimum palette. This takes a long time (). Perhaps because it finds the optimum palette for ALL the loaded files, not only the areas which are selected?

    However when I try JPG in TIFF I get the same error as before,"4GB limit". Have you changed only the LZW? The reason I want to use JPEGTIFF is because it takes a lot of time to find the Optimum Palette in LZW, and I am not sure if all software handles LZW (although I think it should because I guess it is more common with LZW than JPEGTIFF).
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited January 2008
    When you find the optimum palette Global Mapper basically runs through the entire export once without actually writing anything to disk and counts all of the colors that were used, then finds an optimum palette based on that. Then it does the actual export using that optimum palette. So finding the optimum palette basically can almost double the actual export time.

    I think that you are actually hitting the 4 billion (actually 2^32) pixel limit on your 24-bit export and not the 4GB size limit as that would cause the error to always fire. Since TIFF is a 32-bit format, there are problems with some values getting larger than what can be stored in a single 32-bit value, resulting in the TIFF being unreadable. You will need to reduce the size of your TIFF file (either by cropping/gridding or increasing the sample spacing) to get below this limitation, or else use a format that does not have these size limitations, like ECW.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.