Minor Bug - Adding Text Suffix Vector Options Dialog

Roger EdrinnRoger Edrinn Global Mapper UserPosts: 721Trusted User
edited June 2011 in Bug Report
I wanted to add a text suffix to a Feature Name in the OCC > Options > Vector Options > Name Features Using Attribute Value > Use Multiple Attributes.

I wanted a space between the name and text suffix, neither the space option nor the custom field would add a space. I did not test any other options.

The work around was to add the attribute, then add the suffix and space with S&R.

Thought you'd like to know.

BTW GM 12.02 (b061011)

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2011
    That's odd it seems to have worked for me. Can you post a workspace and data files or send them to support@globalmapper.com?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Roger EdrinnRoger Edrinn Global Mapper User Posts: 721Trusted User
    edited June 2011
    Just tried it again, same results.

    - Download this shapefile
    - Open in GM
    - Open CC and delete the Roads layer
    - Select the Trails layer
    - Click Options
    - Delete Name
    - Select TRL_NO in multiple
    - Type "Trail" in the suffix box
    - Select Trail as Line Type
    - OK

    No space between TRL_NO and Trail
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2011
    Ah sorry I missed where you were using the suffix option. The separator is for between the attribute values, it doesn't apply to the prefix or suffix. If you want the space just include that in the suffix text like ' Trail'.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Roger EdrinnRoger Edrinn Global Mapper User Posts: 721Trusted User
    edited June 2011
    Bit embarrassed. I don't use the options setting much anymore, use scripts instead. So I forgot this subtlety.

    Thanks for the reply.
Sign In or Register to comment.