Global Mapper Pro

How to tell GM not reload data from a WMS after zooming in

czietz
czietz Global Mapper UserTrusted User
edited March 2011 in Technical Support
By default GlobalMapper reloads data from a WMS source after zooming (in). Is there a way to prevent this or ‒ even better ‒ to restrict this behavior to certain map scales? Some WMS data sources return empty tiles or an error message for certain zoom levels. It would be better if GM could be setup to just zoom in into the existing image.

Comments

  • global_mapper
    global_mapper Administrator
    edited March 2011
    There currently isn't a way to limit how far you can zoom into a WMS source, although that is a good suggestion and shouldn't be too hard to do. I will look at adding an option to do this and get back to you.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Ice Age Mark
    Ice Age Mark Global Mapper User Trusted User
    edited March 2011
    Hello Mike,

    Sorry to intrude here, but if you're going to be working on this anyway; it would be nice if one could "escape" or disconnect from the online sources when they "hang" during download, or take an excessive amount of time. Currently, it seems that I have to close GM and reload my work and start over when this occurs. This happens most commonly with NAIP imagery for me, but I also use that source the most.

    Thanks,

    Mark
  • global_mapper
    global_mapper Administrator
    edited March 2011
    Mark,

    You can already press the Escape key to abort a draw, including interrupting one being downloaded from the server. Note there may be a delay between pressing Escape and the download aborting as a timeout is waited for. Once the draw aborts you could just turn that layer off.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapper
    global_mapper Administrator
    edited March 2011
    I have added a new right-click option to the Download Online Imagery/Data dialog so that you can right-click on a user-created WMS source and specify a maximum zoom resolution in meters per pixel, beyond which the server shouldn't be accessed. I have placed a new build at http://www.globalmapper.com/global_mapper12.zip with the change for you to try. Simply download that file and extract the contents into your existing v12.xx installation folder to give it a try. If you are using the 64-bit v12 version there is a new build at http://www.globalmapper.com/global_mapper12_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • czietz
    czietz Global Mapper User Trusted User
    edited March 2011
    Thank you for that new feature. It works as expected.
Sign In or Register to comment.