Crash when using Catalog

RecceRecce Global Mapper UserPosts: 178Trusted User
edited February 2011 in Bug Report
Hi

I have a lot of crashes when using Catalog. When moving the map, exporting raster etc.

I rebuild the catalog but no change.

I often receive no error message just a crash to desktop. But lately received this:

Unknown error while rendering overlays, you should probably save and quit.
Write access violation at data address 0x06AED4A0,
program address 0x03576A5D.

Version: v12.01
Build Time: Jan 28 2011 14:34:26


I updated the globalmapper.exe to the latest but no change.

Regards

Thomas

Comments

  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    When using the 64 bit version I get the same error.


    Unknown error while rendering overlays, you should probably save and quit.
    Read access violation at data address 0xFFFFFFFF,
    program address 0x406928C2.

    Version: v12.01
    Build Time: Jan 28 2011 14:33:18


    I am uploading a sample map to you FTP.


    If I zoom in to a smaller area the error from above stops.

    /Thomas
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011

    Global Mapper
    Unhandled exception processing command message.
    Write access violation at data address 0x04408980,
    program address 0x04408980.

    Version: v12.01
    Build Time: Jan 28 2011 14:33:18
    Use Ctrl+V to Paste Error
    OK
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited February 2011
    There were some bugs in the Jan 28th build that you have that are likely causing the issues that you are seeing. The latest build should fix things. I have placed a new build at http://www.globalmapper.com/global_mapper12.zip with the latest changes for you to try. Simply download that file and extract the contents into your existing v12.xx installation folder to give it a try. If you are using the 64-bit v12 version there is a new build at http://www.globalmapper.com/global_mapper12_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    Same error:

    Unhandled exception processing command message.
    Read access violation at data address 0x00000000,
    program address 0x405BA546.

    Version: v12.01
    Build Time: Feb 4 2011 22:29:38


    I am unable to create a new catalog. When using Add dir it finds no GeoTiff files...

    I will test the 32bit version next weekend.

    /Thomas
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited February 2011
    Thomas,

    I just tried your data in the latest build (both 32-bit and 64-bit) and I was able to both create a map catalog from your data and zoom in and out on it without error. I also tried and export and that worked fine as well. When exactly is the error popping up for you in the latest build?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    Mike,

    I load the data and pan around and after a while this pops up:

    Unknown error while rendering overlays, you should probably save and quit.
    Write access violation at data address 0x00000000,
    program address 0x00000000.

    Version: v12.01
    Build Time: Feb 12 2011 17:26:30


    A memory bug?

    This is Vista-64 system with 4 GB ram...

    Is it the size of the catalog file?

    I uploaded the catalog file to your FTP.

    I will test the 32bit version on a XP SP3 using 4 GB Ram.

    /Thomas
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited February 2011
    Thomas,

    It is strange. I cannot reproduce with just the .gmc file. Is it possible for you to upload the actual data files referred to by the map catalog (or at least some for part of the catalog) to the FTP site so I can test with the data?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    Mike,

    I started uploading a exampel data set.

    The error appears if I move the map before the load of the map files is complete.

    32 bit version error:

    Unknown error while rendering overlays, you should probably save and quit.
    Read access violation at data address 0xFFFFFFFF,
    program address 0x0359FFE1.

    Version: v12.01
    Build Time: Feb 12 2011 17:30:48


    /Thomas
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    Testing on a 32 bit XP machine;
    I created a new catalog file and the same error happens. Some time reporting the error message posted above or crash to the desktop.

    I finished uploading the data to your server.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited February 2011
    Thanks for the files. I was able to reproduce the error and get it fixed. I have placed a new build at http://www.globalmapper.com/global_mapper12.zip with the change for you to try. Simply download that file and extract the contents into your existing v12.xx installation folder to give it a try. If you are using the 64-bit v12 version there is a new build at http://www.globalmapper.com/global_mapper12_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    The 32 bit version runs stable now. I will test the 64 bit version later. But I think it is just as fine.

    Thanks!

    /Thomas
  • RecceRecce Global Mapper User Posts: 178Trusted User
    edited February 2011
    I ran into a new problem using the catalog using the 32 bit version (64 bit not tested).

    I made a large catalog file (8 mb) and it work fine. I exit and restart GM and open the Catalog file again. Now it is empty?

    I am uploading the file and some sample data to your FTP.


    Regards

    Thomas
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited February 2011
    Thomas,

    Problem fixed, it had to do with the ampersand (&) in the original save path not being properly stored in the GMC file. I have updated Global Mapper both to read the files even with the error and no longer write them incorrectly. I have placed a new build at http://www.globalmapper.com/global_mapper12.zip with the change for you to try. Simply download that file and extract the contents into your existing v12.xx installation folder to give it a try. If you are using the 64-bit v12 version there is a new build at http://www.globalmapper.com/global_mapper12_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.