Global Mapper Pro Coming Soon

Rotate feature command rotates holes incorrectly

dominocdominoc Global Mapper UserPosts: 18
edited November 2010 in Bug Report
Hello Global Mapper team,

I am using Global Mapper 12 build Oct 11 2010.

I found that the Rotate feature command does not rotate holes in polygons correctly. You may want to check the function.

thanks

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2010
    I just tried with the latest build and rotating holes in polygons seemed to work fine (i.e. they rotated as expected when rotating their parents). What kind of behavior are you seeing?

    Also, can you try the latest build to see if you aren't experiencing a problem that has since been fixed? I have placed a new build at http://www.globalmapper.com/global_mapper12.zip with the latest changes for you to try. Simply download that file and extract the contents into your existing v12.xx installation folder to give it a try. If you are using the 64-bit v12 version there is a new build at http://www.globalmapper.com/global_mapper12_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • dominocdominoc Global Mapper User Posts: 18
    edited November 2010
    I have tried the latest build but the rotate problem persist.

    I should have given you the steps to dup the problem.

    1. Select a polygon with a hole
    2. Click Rotate/scale feature command
    3. Enter 45 for rotation angle
    4. Toggle on About vertex
    5. Click Ok
    -> outer polygon ring is rotated correctly but the hole is not

    I attach a sample file.

    Thanks
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2010
    I just tried this and it worked perfectly for me with the latest build. What are you seeing as your incorrect result?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • dominocdominoc Global Mapper User Posts: 18
    edited November 2010
    Hi Mike

    I've attached 2 screenshots of what I am seeing - before and after.

    thanks
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2010
    Aha the issue only happened if you selected both the parent and and hole/island, then the hole/island was rotated twice. I have placed a new build at http://www.globalmapper.com/global_mapper12.zip with this fixed for you to try. Simply download that file and extract the contents into your existing v12.xx installation folder to give it a try. If you are using the 64-bit v12 version there is a new build at http://www.globalmapper.com/global_mapper12_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.