GM_Error_NotRegistered

codemousecodemouse Global Mapper UserPosts: 186Trusted User
edited August 2010 in SDK
Mike,

This was working fine for us for a while - then all of the sudden (not sure why, trying to trace what happened, if anything, the Global Mapper SDK is no longer working for us).

We are making a call to the wrapper/libraries from C#. The following files are sitting in a directory with a the working directory being the same:

gdiplus.dll
GlobalMapperInterface.dll
gmdll_regkey.txt
gmp-vc90-mt.dll
lti_dsdk_cdll.dll
lit_dsdk_dll.dll
mfc90.dll
msvcp90.dll
msvcr90.dll
NCScnet.dll
NCSEcw.dll
NCSEcwC.dll
NCSUtil.dll
TriangulationLib.dll

I'm trying a variety of calls - Get/Set projection, generate contours, load ASCII layer, generate GeoTIFF, Shape File, etc... and all of them are giving the same error. The machine is 64-bit Win7 - GlobalMapper 64-bit is installed (not that this should matter), the binaries being referenced are all 32-bit.

Again, not sure what happened here. Any thoughts? It hasn't worked for several days - trying to piece together what the issue is. What does the Licensing logic need
to read from that regkey.txt file? Are there any registry reads/writes involved here?

Thanks,

Brian

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited August 2010
    Brian,

    The gmdll_regkey.txt file should live in the same folder as the GlobalMapperInterface.dll file being used. Can you email your gmdll_regkey.txt file to support@globalmapper.com so that I can check it?

    Are the GM_GetProjection and GM_SetProjection functions returning that error code? They should never return that as they don't require registration. The GM_LoadLayerList function shouldn't return that either unless something else is already loaded.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • codemousecodemouse Global Mapper User Posts: 186Trusted User
    edited August 2010
    Mike,

    Emailing right now. It wasn't Get/Set Projection, it was GM_SaveProjectionToFile. And yes, LoadLayer works fine - it was basically all of the export functionalities.

    Brian
  • codemousecodemouse Global Mapper User Posts: 186Trusted User
    edited August 2010
    Mike,

    Any thoughts why I would get that error suddenly across the board?

    Brian
  • codemousecodemouse Global Mapper User Posts: 186Trusted User
    edited August 2010
    Mike,

    Thanks for the help. For everyone else - the problem appeared to be an LF (line-feed) missing from the key file - between entries. That fixed the issue.

    Brian
Sign In or Register to comment.