Global Mapper Pro

Package File Export - Draw Order Not Retained

Roger Edrinn
Roger Edrinn Global Mapper UserTrusted User
edited February 2012 in Vector Data
I have a Workspace with perhaps 2-dozens shapefile layers, all polygons, each ordered such that lesser areas are below more relevant layers. I used the Order Vector Features by Layer Order switch in Config > Vector Display to achieve the correct object order.

I then exported to Package file using the combine compatible vector layers switch. When I opened the package file I had a single layer, that's what I wanted, but my object order was NOT retained, not good.

Is this the expected behavior? Suggestions to retain my object order?

Thanks

Comments

  • global_mapper
    global_mapper Administrator
    edited June 2010
    What's happening is that the features within a layer are always sorted based on type/style for display, so when your features are all moved to the same layer by combining them in a package export, they are then sorted again. You would need to keep them in separate layers so they don't get sorted together, so don't combine the layers on your package export.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Roger Edrinn
    Roger Edrinn Global Mapper User Trusted User
    edited June 2010
    Thanks Mike, but . . .

    Your answer defeats the purpose of combining similar vector layers. I use the feature with small similar layers to reduce menu clutter.

    However, except for the visual layer confusion, it does not matter - to me. Since my ultimate output is MP text and so long as the "hidden" polygons are correctly exported, then my TYPE file ultimately controls draw order and the GM view does not matter.

    I just did a test with the weird package file, all was well. :)
  • Roger Edrinn
    Roger Edrinn Global Mapper User Trusted User
    edited February 2012
    What's happening is that the features within a layer are always sorted based on type/style for display, so when your features are all moved to the same layer by combining them in a package export, they are then sorted again. You would need to keep them in separate layers so they don't get sorted together, so don't combine the layers on your package export.
    I changed my process somewhat (I think?) so I'm going to re-ask this question:

    Let's assume I work all cities as a single workspace, save that, then export all cities as a package file (combining similar vectors). Now I follow the same procedure for counties and now have two different package files, cities and counties.

    Now I start a new workspace where I open all the package files, may have 2-dozen package files. My problem, no matter where I place cities and counties in Overlay Control Center, counties obscures cities. I can only see individual cities if I select a county with the edit tool (border option) or turn off the county "layer" in the OCC.

    Is this the expected behavior? Why can't cities appear on top of counties?

    Thanks for your thoughts.
  • global_mapper
    global_mapper Administrator
    edited February 2012
    Roger,

    What is your 'Vector Layer Order During Draw' setting on the Vector Display tab of the Configuration dialog? This controls the order in which loaded vector layers are drawn. By default the type controls the draw order, with areas always being drawn first, then lines, then points, but if you use the other Vector Layer Order During Draw setting then the order of the layer in the Control Center is what determines the display order for vector features.

    Thanks,

    Mike
    Global Mapper Guru
    gmsupport@bluemarblegeo.com
    http://www.globalmapper.com
  • Roger Edrinn
    Roger Edrinn Global Mapper User Trusted User
    edited February 2012
    Roger,

    What is your 'Vector Layer Order During Draw' setting on the Vector Display tab of the Configuration dialog?
    Bingo!!!

    Don't know I've ever seen/adjusted that switch.

    Thank you Mike :)
Sign In or Register to comment.