Global Mapper Pro

Avoiding gradients in generated elevation bitmaps of flat plane polygons

mattp52
mattp52 Global Mapper User
edited December 2010 in Elevation Data
Hi,

I'm generating a colored bitmap from an imported DWG file containing building footprints with elevation attributes. It's mostly working when I generate an elevation bitmap from this, but some areas appear to be interpolating heights from an adjacent building, causing the height color to render as a gradient rather than a flat color. If I offset a feature so it's not near an adjacent poly edge the problem is resolved but I'd rather not do that?

Any suggestions for a fix here?

Cheers.

Comments

  • global_mapper
    global_mapper Administrator
    edited May 2010
    When you generate the elevation grid from the buildings are you checking the option to flatten the area features? If you do this then the area between the buildings should be marked as void and I think you'll get what you want.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mattp52
    mattp52 Global Mapper User
    edited May 2010
    Thanks for the reply. I am yes. I've got the following checked:-
    • Use 3D Line Features as Constraints
    • Flatten 3D reas
    • Ignore Zero Elevations

    The attached file shows the effect I'm getting.
  • global_mapper
    global_mapper Administrator
    edited May 2010
    Ah, I thought you were getting interpolation between separate buildings. Try turning off resampling/anti-aliasing for your generated grid layer on the Options dialog for the grid layer and see if that helps. I think you are just seeing the default interpolation between adjacent grid cells for an elevation layer. Setting the resampling method to 'Nearest Neighbor' should eliminate that.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mattp52
    mattp52 Global Mapper User
    edited May 2010
    Unfortunately no change using 'Nearest Neighbour' in the image rectification settings. As the data contains an attribute for elevation in each area, I would've assumed the software could generate a flat colour using that attribute within the bounds of the area. The numbers displayed in the previous upload are the elevation attributes for each area.

    If that's not possible is there a way to ramp the interpolation so it occurs very near the edges of the area bounds so the main area's colour is mostly uniform?

    Cheers
  • global_mapper
    global_mapper Administrator
    edited May 2010
    Can you provide a sample of the data that you are working with so that I can see what is happening? I would expect the non-uniform result unless your areas actually have 3D vertices with different values rather than just a single elevation.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mattp52
    mattp52 Global Mapper User
    edited May 2010
    Sure. Attached is a zip file with a small section of the file in Shape format containing area features with height elevations. Selecting the overlay and generating an elevation raster produces the interpolation.

    The only way I can get around this is by selecting each area individually, switching off elevation overlays of adjacent features and using the Digitizer "Create Flatten Terrain from Selected Area(s)" command.
  • global_mapper
    global_mapper Administrator
    edited May 2010
    When I try your data and create an elevation grid from the entire layer and flatten areas, then use Nearest Neighbor for resampling and also turn off hill shading I don't get any interpolation. Did you also make sure the option to taper areas was unchecked when generating the grid?

    I have attached a screenshot of what I'm seeing.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • mattp52
    mattp52 Global Mapper User
    edited May 2010
    Thanks for trying that data. You're getting what I'd expect to see but repeating that process I get interpolated results. I'm using a v9 release of GlobalMapper so I can only put it down to a difference in versions?
  • chuckyeager69
    chuckyeager69 Global Mapper User Trusted User
    edited December 2010
    I am seeing this issue in version 12 as well, i have lidar point data and want it to not interpolate.
  • global_mapper
    global_mapper Administrator
    edited December 2010
    The resampling (interpolation) is done after grid generation. To get rid of it simply go to the Options dialog for the layer and change the Resampling method to 'Nearest Neighbor', which disables interpolation.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Davidbumstead28
    Davidbumstead28 Global Mapper User
    edited December 2010
    KAYWEB brings you World Wide Web Design, SEO, Web Development, Web Designers and more. Our Website Design services are Multi Award Winning.
Sign In or Register to comment.