Global Mapper Pro

NAIP Color Imagery for US Now Built-In!

global_mapper
global_mapper Administrator
edited May 2011 in Announcement and News
I have just discovered a WMS data source from the USGS providing free access to the 1m color NAIP imagery for the entire US, so I have added this to the list of built-in sources available on the File->Download Online Imagery menu command. Now you can all access that imagery for free and with no new software download. Just restart Global Mapper and it should be there!

Let me know if I can be of further assistance.

Thanks,

Mike
Global Mapper Support
support@globalmapper.com

Comments

  • EDGAR
    EDGAR Global Mapper User Trusted User
    edited March 2010
    Yes, it works as You said.

    Thanks, and regards
  • daver819
    daver819 Global Mapper User Trusted User
    edited March 2010
    Great upgrade!
  • DaveGoodrich
    DaveGoodrich Global Mapper User Trusted User
    edited March 2010
    I have a question regarding this data. The data resolution says it is 1m/pixel, but when I attempt to export the data to GeoTiff, GM defaults to 0.1 m/pixel. Obviously, this leads to very large file sizes. Is this intentional? Can I change the export resolution to 1m/pixel without losing image quality?
  • global_mapper
    global_mapper Administrator
    edited March 2010
    That's just the default resolution used for WMS data sources in Global Mapper if they don't explicitly specify a max resolution. So far all of the NAIP imagery is 1m resolution, but there's no reason in the future that higher resolution wouldn't become available, so the default is 0.1m (doubt it will go higher than that for a while) since the NAIP server doesn't explicitly list its resolution.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • DaveGoodrich
    DaveGoodrich Global Mapper User Trusted User
    edited April 2010
    Thanks for the info.

    So is there a way to determine the export resolution that will minimize file size while preserving all of the original image data?
  • global_mapper
    global_mapper Administrator
    edited April 2010
    For now since the NAIP imagery is 1m resolution just change the resolution to 1m in each direction on export and that should do it for you.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Piccoro2k
    Piccoro2k Global Mapper User
    edited July 2010
    Hello recently when I try to download Naip images I get this error

    Error loading WMS data source.
    Unable to find database 0 on server.
    OGCWMSOverlay.cpp - 3084
    Build Time: Oct 5 2009 23:09:25


    can anyone tell me how can I solve this problem?
  • global_mapper
    global_mapper Administrator
    edited July 2010
    The WMS NAIP server from the USGS has been having this problem off and on lately. I'm guessing they are doing some work on the server that's causing this. They will hopefully have it working again shortly.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • DaveGoodrich
    DaveGoodrich Global Mapper User Trusted User
    edited August 2010
    The NAIP server has been down for weeks. It doesn't seem to be "on and off" for me, just "off." Anybody know what is happening? Has the server changed or something?

    Thanks,
  • global_mapper
    global_mapper Administrator
    edited August 2010
    The NAIP server was down for a couple of weeks (with it being briefly up a couple of times during that period), but should have been fine now for a couple of weeks. I actually emailed them about the problem and them emailed back when they fixed the issue a couple of weeks ago. It is working fine for me. Are you still having issues?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • DaveGoodrich
    DaveGoodrich Global Mapper User Trusted User
    edited August 2010
    Yes, I just checked it. I get the error:

    Error loading WMS data source.
    Unable to find database 0 on server.
    OGCWMSOverlay.cpp - 2970
    Build Time: May 7 2009 10:02:13
  • global_mapper
    global_mapper Administrator
    edited August 2010
    It looks like the USGS has broken it again (in the same way as before), I was just getting a cached copy of their GetCapabilities WMS document so it worked for me. I have emailed them again so that they can fix this again. I would keep trying over the next few days until they have it fixed again.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • kalden
    kalden Global Mapper User
    edited August 2010
    How do I access this server through the SDK? Do I need an updated library?
  • global_mapper
    global_mapper Administrator
    edited August 2010
    Using the latest SDK, just use the GM_LoadOnlineLayer function to load any built-in online layer, include the NAIP source.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • bjcwheeler
    bjcwheeler Global Mapper User
    edited August 2010
    Any chance we can add this resource from the USDA for NAIP:
    gis.apfo.usda.gov

    NAIP for the entire US including CIR.
  • global_mapper
    global_mapper Administrator
    edited August 2010
    Is there a WMS source on that site and is it in any way different than the existing NAIP WMS from the seamless.usgs.gov site that is already built in to Global Mapper?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • DaveGoodrich
    DaveGoodrich Global Mapper User Trusted User
    edited August 2010
    Just a FYI. The NAIP WMS server seems to be working again (as of 8/31/10). Hopefully they have fixed whatever issue they were having.
  • global_mapper
    global_mapper Administrator
    edited August 2010
    Even if they haven't fixed it, both v12 and the latest v11 build have a work-around for the problem they kept having (i.e. corrupt GetCapabilities) request, so if they do the same thing yet again it should still work through Global Mapper (and will likely be faster since no other software will be able to use the server right then!).

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • RGEarley
    RGEarley Global Mapper User Trusted User
    edited May 2011
    I was having used this data source quite a bit over the past year, few if any problems since August. Yesterday I was having trouble with the image not registering in the right place relative to my vector layers, on a project I had done this past January. I tried flushing the cache in the "Download Online Imagery/Topo/Terrain Maps" dialog, and then it would only load small pieces and then stop (The whole area was only 1-2 square miles) . I found the usgs link below and added a new source to my Global Mapper using that link - it is slightly different than the built-in link:

    http://isse.cr.usgs.gov/ArcGIS/services/Combined/SDDS_Imagery/MapServer/WMSServer
    Service Name: WMS&request=GetCapabilities
  • global_mapper
    global_mapper Administrator
    edited May 2011
    Thanks for the link, I'm checking with the US to see what the difference is between that source and the one in Global Mapper.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.