Global Mapper Pro

Downloading from WMS server that doesn't support EPSG:4326

czietz
czietz Global Mapper UserTrusted User
edited February 2010 in Downloading Imagery
Hi,

I'd like to download data from a WMS server that doesn't support EPSG:4326 as SRS. (This fact is also stated in the answer to the GetCapabilities request.) Is there a way to tell GM (v.10 or v.11) to use another SRS for the GetMap request?

Christian

Comments

  • global_mapper
    global_mapper Administrator
    edited February 2010
    Christian,

    What you can do is add the desired EPSG code to the service name when adding the service, like 'WMS&SRS=EPSG:4326' (use the desired EPSG code of course). If that doesn't work, let me know what EPSG code the server is using as it's possible GM simply doesn't recognize that EPSG code yet, but I can add it (actually you can add it as well to the epsg_codes.txt file, but I'd rather just build it in so others can use it).

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • czietz
    czietz Global Mapper User Trusted User
    edited February 2010
    Unfortunately, adding the desired SRS to the service name doesn't change anything. I still get an error message saying
    Error downloading WMS data tile
    freezoneogc/mapserverogc?VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=TK100&FORMAT=image/png&STYLES=&SRS=EPSG:4326&BBOX=9.580146969,52.5370120487,9.6387639081,52.5956289878&WIDTH=512&HEIGHT=512


    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE ServiceExceptionReport SYSTEM "http://www.mapserver.niedersachsen.de/exception_1_1_1.dtd"&gt;
    <ServiceExceptionReport version="1.1.1">
    <ServiceException code="InvalidSRS">Request contains an SRS not offered by the service instance for one or more of the Layers.</ServiceException>
    </ServiceExceptionReport>

    The WMS server address in question is http://www.mapserver.niedersachsen.de/freezoneogc/mapserverogc. It supports EPSG:31467.
  • global_mapper
    global_mapper Administrator
    edited February 2010
    What version of GM are you using? When I created a new source with the service name set to 'WMS&SRS=EPSG:31467' that SRS is used rather than 4326.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • czietz
    czietz Global Mapper User Trusted User
    edited February 2010
    Strange, it works now after I deleted the WMS source and added it again. Maybe I did something wrong the first time while setting the service name.

    Anyway, thank you, Mike.
Sign In or Register to comment.