Global Mapper Pro

Import large text (elevation) file

juddpatterson
juddpatterson Global Mapper User
edited December 2009 in Elevation Data
I have 7 sonar files (ASCII Text format; tab separated; easting, northing, elevation) that range in size from 250MB to 1GB. Each time I try to import the biggest files, I get an out of memory error. I've checked in Task Manager and I always have >2GB of RAM free when the error occurs. Is there a trick that I can use to successfully convert these large text files to a GeoTIFF? Just as a note, I was able to convert the 250MB file to a GeoTIFF. Thanks!

Comments

  • global_mapper
    global_mapper Administrator
    edited December 2009
    What version of Windows and Global Mapper are you running? If you have 32-bit Windows or 32-bit Global Mapper then you are basically limited to 2GB of memory usage by Global Mapper. If you have 64-bit Windows the 32-bit GM can use up to 4GB of memory, and with the 64-bit GM on 64-bit Windows you can use much more memory. I suspect you will need the latter to load files of the larger size.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • juddpatterson
    juddpatterson Global Mapper User
    edited December 2009
    Right now I'm running GlobalMapper 10 on a 32-bit Windows XP machine. I just tried the conversion a second time and the "Out of Memory" error occurs when GlobalMapper hits a memory usage ~350MB...quite a bit below the 2GB limit you mention. Any idea what is going on?
  • global_mapper
    global_mapper Administrator
    edited December 2009
    That is strange. Are you trying to load your data as "Point Only" or creating an elevation grid out of it? What v10 version are you using?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • juddpatterson
    juddpatterson Global Mapper User
    edited December 2009
    I'm using version 10.02. I was trying to create an elevation grid. This time I did point only and at 1.6GB of memory usage I get:
    "Unexpected error while rendering overlays. Out of memory."
  • global_mapper
    global_mapper Administrator
    edited December 2009
    There is a lot of extra memory required to triangulate a grid the point data set. I'm guessing you are running out of memory when the grid is allocated in memory during the operation as it would require a large contiguous chunk of memory.

    What I would suggest doing is pulling the data in as "Point Only", then opening the Control Center, right-clicking on the layer, then selecting the option to grid the data. One the dialog that appears use the Gridding tab to break the operation into smaller chunks (say a 2x2 grid) and check the box on the first tab of the dialog to export directly to GMG files. This should significantly reduce the required memory and hopefully allow you to get the data gridded. You can just load the created GMG files back in once the operation completes.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.