Global Mapper Pro

maxLodPixels for Google Earth SuperOverlays

Matt
Matt Global Mapper UserTrusted User
edited November 2009 in Bug Report
I think during one of the version updates, the behavior of how maxLodPixels for SuperOverlays is calculated was changed. This value should always be -1 for SuperOverlays but GM 11.01 is now calculating a value for this figure (in previous versions it correctly used -1).

If it's not -1, then the tiles do not overlap and instead of a nice smooth transition going from one detail level to the next, you get tiles popping in and out of view. Or at least give us the option in script to set this value to -1.

Thanks

Matt

Comments

  • global_mapper
    global_mapper Administrator
    edited November 2009
    Matt,

    There was recently a change so that the lower detail levels in a super overlay don't use a <maxLodPixels> of -1 but instead use a value that should cause the lower zoom level to go away just when the next zoom level of tiles comes on. The maximum detail zoom level should have a <maxLodPixels> of -1 so that it always stays on.

    This change was made because without it the higher levels stay on even when the lower zoom levels show up, which causes fuzziness in images with internal transparency.

    Are you seeing the images pop in and out in Google Earth? Can you provide me with a sample super overlay that exhibits this behavior? There could be a calculation issue with the maxLodPixels values or something.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Matt
    Matt Global Mapper User Trusted User
    edited November 2009
    I think what I'm seeing is expected behavior based on how GM is programmed. Just that in most cases a value of -1 for all layers works better because as you zoom in the map tiles load on top of each other instead of turning off. When they turn off, what ends up happening is there will be moments as the next level of tiles are loading where no map data is visible, and the ground beneath becomes visible. You then see the tiles load one by one on top of the ground textures.

    When they load on top of each other, what you get is a slightly blurry image that becomes more clear as the tiles load. But the ground textures never become visible. This is a much better transition effect.

    Perhaps a check box in the options for "Image Uses Transparency" or a maxLodPixels option in the scripting language would let the user decide which option to use.
  • global_mapper
    global_mapper Administrator
    edited November 2009
    Matt,

    Ok, so the problem is the pause while the new zoom level layers are being loaded. I'll update the export to use -1 for the <maxLodPixels> when transparent images aren't being used, then get you a new build.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapper
    global_mapper Administrator
    edited November 2009
    Matt,

    I have updated the KML super overlay export so if you choose an image format that doesn't have internal transparency (currently only JPG) then the old behavior of a <maxLodPixels> value of -1 for every tile will be used. For image formats that may have transparency the current behavior will be maintained.

    I have placed a new build at http://www.globalmapper.com/global_mapper11.zip with the change for you to try. Simply download that file and extract the contents into your existing v11.xx installation folder to give it a try. If you are using the 64-bit version, there is a new build available at http://www.globalmapper.com/global_mapper11_64bit.zip .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.