Script error

DustyRobinsonDustyRobinson Global Mapper UserPosts: 114Trusted User
edited November 2009 in Technical Support
I am trying to batch process some image tiles. I have a script created that should export images clipped with loaded polygons. I would like to export to JPG200 and I have that designated for the TYPE= in the script. When I run the script in GM I get an error message for "Unknown TYPE value <JPG2000>. Am I naming it wrong, or is something am I missing something else?

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2009
    You need to use TYPE=JPEG2000, not TYPE=JPG2000.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • DustyRobinsonDustyRobinson Global Mapper User Posts: 114Trusted User
    edited November 2009
    I changed the image format to JPEG2000 and ran the script again and two odd things happened. GM started running and said it was creating an ECW file (see attached image). When I checked the temp file it was making it had jp2 in the text, so I thought everything was still working ok. It created all the files, but they are all essentially blank files and have no jp2 extensions. Any suggestions?
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited November 2009
    You need to add an extension to your FILENAME parameter in the export command. For example, use FILENAME="H:\32-144600_Kinzua_Dam\Geo Data\Imagery\PAMAP_Tiles\PAMAP_PASPZ_N_USft_.jp2". The ECW and JPEG2000 exporter use the same library, so the progress bar may be a bit confusing.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.