Global Mapper Pro

GPX Files

Ollie
Ollie Global Mapper User
edited July 2009 in Bug Report
Hello
When I load and then save a GPX file with time data the saved file has different time information.
My setup is Windows XP : GM 10.02 Build Time June 18 : Clock GMT Dublin, London Allow adjustment for daylight saving. Results in GMT +1 currently.

If a file with a point with a time stamp of say 08:00 is loaded. When I look at this using the Info Tool the GM display will show 10:00. I would expect 09:00 If the loaded information is saved out to a gpx file the point will have a time associated with it of 09:00. I would expect 08:00 I do not think this behavoir is correct or am I missing something.

Regards
Ollie

Comments

  • global_mapper
    global_mapper Administrator
    edited July 2009
    Ollie,

    I think something is going wrong with the daylight savings time setting somewhere in the conversion. If you can post the GPX file or email it to support@globalmapper.com I can take a look.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Ollie
    Ollie Global Mapper User
    edited July 2009
    Mike,
    I emailed you sample files and from your reply email you cannot see the effect. From my original post you can see my setup. On further trials the problem seems to be associated with the automatic daylight setting.
    If I set the time zone to GMT Dublin,London and do not have automatic daylight saving enabled, load |GM 10.02 and then the sample file 001 and save it all is OK
    If I set the time zone to GMT Dublin,London and enable automatic daylight saving, load GM and then the sample file 001 the incorrect data is displayed by Info and the incorrect data is saved as outlined in my original post

    Regards
    Ollie
  • global_mapper
    global_mapper Administrator
    edited July 2009
    Ollie,

    I'll try switching my computer to your settings later today and see if I can reproduce the issue.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • global_mapper
    global_mapper Administrator
    edited July 2009
    Ollie,

    I tried switching my clock to use the Dublin/London time zone with automatic daylight saving's time adjustment set, but I saw 9:00 in the Feature Info dialog and the exported GPX file maintained the original 8:00 setting, which is what you expected to happen but apparently not what happened on your machine.

    However, this was in the current Global Mapper v11 beta build. If I go back and try in v10.02 then I see the same behavior that you were, so it looks like you are experiencing something that has been fixed. I think this is related to our upgrade from a very old development environment (VC6.0) for Global Mapper v10 to the latest (VS2008) for Global Mapper v11.

    If you want to try the v11 beta, you can get it from GIS Software Download - Topographic Mapping Software - Mapping Software With GPS .

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Ollie
    Ollie Global Mapper User
    edited July 2009
    Mike
    Thanks for the reply. I will just work around the problem for any files where the time stamp is important.

    Regards
    Ollie
Sign In or Register to comment.