Export Google Maps Tiles introduces unwanted anti-aliasing

Kyle EstesKyle Estes Global Mapper UserPosts: 13
edited October 2009 in Technical Support
I am exporting a GeoTIFF raster to Google Maps tiles and am getting unwanted anti-aliasing, but only at zoom levels 0 through 12 (zoom levels 13 through 15 are not anti-aliased, which is what I want). I am using Global Mapper 10.02. Here are exact steps for reproducing:
  1. Open "test.tif"
  2. File > Export Web Formats (Google Maps, VE, WW, etc.) > Export Google Maps Tiles...
  3. Choose "Level 15 - 4.8 meters/pixel"
  4. Enter "16" for number of zoom levels to use (will create Z0 through Z15)
  5. Click "OK"
  6. In the resulting files, open Z12\1634\2737.png in an image editor. Zoom in. Note that it has anti-aliasing. Now open Z13\3269\5475.png. Note that it has no anti-aliasing.

I have attached "test.zip" which contains "test.tif" and a folder called "test" containing the output of the Google Maps tiles I created.

How can I configure Global Mapper to never anti-alias when exporting to Google Maps tiles?
test.zip 107.1K

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2009
    I took a look and was able to find the problem and fix it. I have placed a new build at http://www.globalmapper.com/global_mapper10.zip with the change for you to try. Simply download that file and extract the contents into your existing v10.xx installation folder to give it a try.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Kyle EstesKyle Estes Global Mapper User Posts: 13
    edited June 2009
    Hi Mike,

    Excellent, thank you for the quick reply and for posting the updated build. Unfortunately, I anti-aliasing still occurs with the new build. I double-checked that I was indeed using the new build, and did so on a couple different computers. Any thoughts?

    Thanks,

    Kyle
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2009
    Kyle,

    I just ran the test again and found that no interpolation was done. I have attached the Z12 2737.png file that was interpolated in yours that no longer is.

    Just in case I didn't update the build right on the network, I have placed a new one that I have just tried at http://www.globalmapper.com/global_mapper10.zip for you to try.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • Kyle EstesKyle Estes Global Mapper User Posts: 13
    edited June 2009
    Hi Mike,

    Thanks again, I really appreciate the assistance.

    Still not working for me; I wonder if there might be some option I'm failing to set, or some configuration requirement I'm unaware of. To that extent, here are the options I'm aware of that have to do with anti-aliasing:
    • Tools > Configure... > General > Automatically Anti-Alias Raster Layers when Loaded. I have this box unchecked.
    • Tools > Control Center... > Raster Options dialog > Anti-Alias Pixels (Interpolate). I have this box unchecked.
    • In several export dialogs (e.g., when exporting a GeoTIFF), you can choose to interpolate. I don't think this is relevant for this discussion, though.

    Another thought: could there be other DLLs or ancillary files that allow the fix to work on your machine?

    P.S.: Just so you know, I ran WinMerge on both of the binaries you posted, the first and second are identical, bit for bit. So I think we can rule that out.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2009
    That is very strange. It sounds like you have all of the options set properly. If you go to the Help->About dialog, what does the build date say? I'm just wondering if perhaps you have an older build running or something and you got a cached build from the server.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • NateNate Global Mapper User Posts: 9
    edited June 2009
    Hi Mike,

    I work with Kyle. We are using GM with a build date of Jun 24, 09 14:14:09.

    One thing we did notice is that if we tile using GM 10.00 it doesn't have the AA problem (but we lose the file structure).

    ~Nate
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2009
    There was a change between v10 and v10.02 that caused the AA to happen when zoomed way out, but unless you have something else loaded, like some vector data or are perhaps including a distance scale on your output, the new build should fix it.

    I'm curious why the AA is an issue at all since it only happens when zoomed so far out on the data that the multiple individual pixels would be blurred into one anyway. It seems that the AA would improve the appearance in that zoomed out case anyway.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • NateNate Global Mapper User Posts: 9
    edited June 2009
    Although we didn't have any vector data loaded in the test file we uploaded, we do use vector data in our production. We are interested with the AA because we test pixel colors at different zoom levels and AA can alter the final result.

    ~Nate
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited June 2009
    Nate,

    I can't think of why the new build isn't working, but there is another way to complete disable the automatic interpolation that is happening when zoomed out. What you need to do is close Global Mapper, then run 'regedit', then add the value 262144 (2^18) to the 'HKEY_CURRENT_USER\Software\Global Mapper\MiscOpts' value. Then when you run Global Mapper the zoomed out auto-interpolation should be disabled.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • NateNate Global Mapper User Posts: 9
    edited June 2009
    Thanks Mike. The registry change worked with the new build (but not the old).

    One thing you guys may want to consider for the next release also is skipping tiles that have no data in them.

    Thanks for the help. You guys have some of the best tech support out there.
  • Kyle EstesKyle Estes Global Mapper User Posts: 13
    edited June 2009
    Mike, that was exactly what we needed. Thank you for providing excellent technical support!

    Kyle
  • soulsolutionssoulsolutions Global Mapper User Posts: 5
    edited October 2009
    opposite problem - I have shape file of property boundaries I'd like to export as Virtual Earth tiles. At street level I just get jagged lines, how do I enable anti-aliasing to make these smoother?

    I found the 1st option mentioned here but it didn't seem to change anything, the data is of style "unknown area type"

    thanks.
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited October 2009
    There is not currently any support in Global Mapper for anti-aliased rendering of line features. The anti-aliasing option is really just for interpolation of raster image layers.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.