ECW Export

TomDavisTomDavis Global Mapper UserPosts: 11
edited September 2008 in Technical Support
I have a mosaic of 932 SID files that total 3.55 GB. I would like to export the mosaic to 1 ECW file. Global Mapper 10 slows to a barely perceptible crawl at 13% completion. Is there anything I can do to remedy this?

Thanks.

-- Tom

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2008
    Tom,

    Has the export ever progressed beyond 13%? You might try using the File->Create New Map Catalog menu command to create a map catalog from your SID files rather than loading them all at once, then export from that and see if it makes any difference.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • TomDavisTomDavis Global Mapper User Posts: 11
    edited September 2008
    Thank you for your reply, Mike.

    I let the mosaic run over the weekend and got to 17% before suffering a file write error.

    I tried exporting from a map catalog without success. I let it run overnight but never got beyond 0%; all temporary files were empty.

    Any other suggestions?

    -- Tom
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2008
    Tom,

    What was the file write error that you received? Does your target disk drive for the export have enough space for the resulting ECW file and any temporary files?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • TomDavisTomDavis Global Mapper User Posts: 11
    edited September 2008
    Mike --

    I do not recall the file write error, but the media is ample. There are 643 GB available, and the largest temporary file was on the order of 1 GB.

    -- Tom
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2008
    Tom,

    I'm wondering if perhaps one of the SID files has a corrupt region at its most detailed resolution layer. Is it possible for you to use the Gridding tab when doing your export to break the export into smaller pieces? Then if one of those pieces failed you could just restart the export where you left off (there is an option on the Gridding tab for skipping existing files to allow this). If the same tile failed again that would indicate a likely probelm in one of the input files.

    You might want to do the first gridded export to GeoTIFF files as they are lossless (unless you do JPG-in-TIFF) and you have the disk space available. Then if that succeeds and you haven't identified any problem input files, you can then try loading all of the GeoTIFF files and exporting from them to a single ECW file.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • TomDavisTomDavis Global Mapper User Posts: 11
    edited September 2008
    Mike --

    Exporting the sid mosaic to geotiff files and subsequently exporting the geotiff mosaic to an ecw file worked well. There appears to be little degradation of image quality, but the ecw is shifted, resulting in poorer rectification. Is this a problem that I can solve?

    -- Tom
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2008
    Tom,

    What size of shift are you seeing and are you seeing it in Global Mapper or elsewhere? Are the intermediate GeoTIFF files shifted as well or just the resulting ECW file?

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • TomDavisTomDavis Global Mapper User Posts: 11
    edited September 2008
    Mike --

    I am observing the shifts in exported jpegs that are georeferenced in AutoCAD using coordinates from the world file.

    Images cut from geotiffs are also shifted, but not the same as images cut from either the ecw file or the original sids. In any event, the shifts are 1 pixel (1 ft) or less, and I think we can close this support request.

    Thank you very much; you were most helpful.

    -- Tom
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited September 2008
    Tom,

    You might try enabling anti-aliasing (interpolation) for all of your layers in Global Mapper prior to export. That way if any export samples don't align perfectly with a pixel in the input you'll get an interpolated result which should reduce visible shift.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.