Memory Error

bcastellobcastello Global Mapper UserPosts: 40
edited July 2008 in Bug Report
Running GM on a XP64 machine with 8GB of memory, I'm getting the following error:

Unknown error while rendering overlays, you should probably save and quit.
Error allocating strip of size 51912025.
Not enough storage is available to process this command.

TIFFOverlay.cpp - 433
Build Time: Apr 30 2008 10:25:22


I'm pasting the metadata for one of the example tiles here:

FILENAME=F:\mapping\processed\N23-W117.tif
DESCRIPTION=N23-W117.tif
UPPER LEFT X=-117.0000000000
UPPER LEFT Y=24.0000000000
LOWER RIGHT X=-116.0000000000
LOWER RIGHT Y=23.0000000000
WEST LONGITUDE=117° 00' 00.00" W
NORTH LATITUDE=24° 00' 00.00" N
EAST LONGITUDE=116° 00' 00.00" W
SOUTH LATITUDE=23° 00' 00.00" N
COVERED AREA=4388 sq mi
NUM COLUMNS=7205
NUM ROWS=7205
NUM_BANDS=4
PIXEL WIDTH=0.0001388 arc degrees
PIXEL HEIGHT=0.0001388 arc degrees
TIME=2008:07:08 17:52:01
PHOTOMETRIC=RGB Full-Color
BIT_DEPTH=32
ROWS_PER_STRIP=7205
COMPRESSION=None
PIXEL_SCALE=( 0.000138793, 0.000138793, 1 )
TIEPOINTS=( 0.00, 0.00, 0.00 ) --> ( -117.0000000000, 24.0000000000, 0.0000000000 )
MODEL_TYPE=Geographic lat-long system
RASTER_TYPE=Pixel is Area
OVERVIEW 1=Pixel Size: 3603 x 3603
OVERVIEW 2=Pixel Size: 1802 x 1802
OVERVIEW 3=Pixel Size: 901 x 901
OVERVIEW 4=Pixel Size: 451 x 451
OVERVIEW 5=Pixel Size: 226 x 226
OVERVIEW 6=Pixel Size: 113 x 113

The error message does not appear unless I use the HOME button to zoom out to the full extent of the loaded tiles. The tiles are all 276MB in size. Previously, i have loaded many more tiles without a problem - but now I'm only able to load less than 20 before this error message appears.

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2008
    What application generated this file? It has a very strange setup in that it has all of the data in the entire file in a single "strip", which is a unit used for extracting data from the TIFF file. So when Global Mapper needs to access data in the full it basically has to decode the entire file into memory, which is very bad for memory usage. Typically applications will create files with a "ROWS_PER_STRIP" value between 1 and 64 or so, not the entire height of the image.

    In any case, to better manage this I would suggest using the File->Create New Map Catalog menu command to create a map catalog from the TIFF files. The map catalog would handle automatically loading and unloaded the files as needed for display and export.

    Another option would be to use the File->Batch Convert/Reproject menu command to batch convert your files from the current TIFF to new GeoTIFF files created by Global Mapper. The new Global Mapper generated files would be oriented in a way that allows for more efficient access. You would lose the overview layers though.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • bcastellobcastello Global Mapper User Posts: 40
    edited July 2008
    Photoshop - the files were saved with the pixel order set to PER CHANNEL instead of INTERLEAVED.

    Is there a way to fix this in a batch mode without losing the overviews?
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2008
    I guess with applications like Photoshop that always read everything into memory anyway the organization of the files that they store isn't so critical. I wonder if choosing the INTERLEAVED option would change things.

    In any case, there is not any way to maintain the overviews when saving new TIFF files from Global Mapper as Global Mapper only supports reading overview layers and not writing them.

    I would suggest just using map catalogs to get around the issue, or perhaps batch converting to ECW or JPEG2000 as they will have what basically amounts to overview layers. If you set the compression target to its lowest setting the results should be lossless as well.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • bcastellobcastello Global Mapper User Posts: 40
    edited July 2008
    Here is the metadata for the file re-saved with the INTERLEAVE option set:

    FILENAME=C:\DOCUMENTS AND SETTINGS\BCASTELLO\DESKTOP\N69-E023-INTERLEAVED.TIF
    DESCRIPTION=N69-E023-INTERLEAVED.TIF
    UPPER LEFT X=23.0000000000
    UPPER LEFT Y=70.0000000000
    LOWER RIGHT X=24.0000000000
    LOWER RIGHT Y=69.0000000000
    WEST LONGITUDE=23° 00' 00.00" E
    NORTH LATITUDE=70° 00' 00.00" N
    EAST LONGITUDE=24° 00' 00.00" E
    SOUTH LATITUDE=69° 00' 00.00" N
    COVERED AREA=1676 sq mi
    NUM COLUMNS=7205
    NUM ROWS=7205
    NUM_BANDS=4
    PIXEL WIDTH=0.0001388 arc degrees
    PIXEL HEIGHT=0.0001388 arc degrees
    TIME=2008:07:22 10:48:06
    PHOTOMETRIC=RGB Full-Color
    BIT_DEPTH=32
    ROWS_PER_STRIP=1
    COMPRESSION=None
    PIXEL_SCALE=( 0.000138793, 0.000138793, 1 )
    TIEPOINTS=( 0.00, 0.00, 0.00 ) --> ( 23.0000000000, 70.0000000000, 0.0000000000 )
    MODEL_TYPE=Geographic lat-long system
    RASTER_TYPE=Pixel is Area
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited July 2008
    That would work much better. Notice the ROWS_PER_STRIP value is 1 rather than the entire pixel height of the image. You don't have any overview layers though. I wonder if perhaps Photoshop only uses the weird organization when overview layers are present. You might try with that option (the pyramid one) checked and see what you get then.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
Sign In or Register to comment.