Global Mapper v25.0

DOS batch file help

moonbaby
moonbaby Global Mapper User
edited June 2008 in Technical Support
I made a script but was wondering how i set this up to run as a DOS Batch? Here is what i have for my script....

GLOBAL_MAPPER_SCRIPT VERSION=1.00
UNLOAD_ALL

IMPORT FILENAME="C:\unzipped\us_temphazards\temp_hazards.dbf" ANTI_ALIAS=YES
IMPORT FILENAME="C:\unzipped\us_preciphazards\precip_hazards.dbf" ANTI_ALIAS=YES
EXPORT_VECTOR FILENAME="C:\Documents and Settings\My Documents\6-10_temp\temps.txt" TYPE=SIMPLE_ASCII EXPORT_ELEV=NO EXPORT_ATTRS=YES

Comments

  • global_mapper
    global_mapper Administrator
    edited May 2008
    To run a script from DOS in batch mode, simply call Global Mapper with your script filename as the parameter from your batch file. For example, the following:

    "C:\Program Files\GlobalMapper9\global_mapper9.exe" "c:\test\my_script.gms"

    This will run the script and then immediately exit without showing a user interface.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • moonbaby
    moonbaby Global Mapper User
    edited May 2008
    To run a script from DOS in batch mode, simply call Global Mapper with your script filename as the parameter from your batch file. For example, the following:

    "C:\Program Files\GlobalMapper9\global_mapper9.exe" "c:\test\my_script.gms"

    This will run the script and then immediately exit without showing a user interface.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com


    Thank you much for the help...worked perfectly!
  • moonbaby
    moonbaby Global Mapper User
    edited June 2008
    Is there an option to not include the "Drawing Style Attributes Before Coordinate Data" when using the SIMPLE_ASCII EXPORT in DOS batch mode? I'm just wanting the "Include Feature Attributes Before Coordinate Data"

    Thanks!
  • global_mapper
    global_mapper Administrator
    edited June 2008
    There wasn't a way to do that, but I've gone ahead and added the ability to specify a parameter value of EXPORT_ATTRS=NO_STYLE to disable the style attribute export when generating attributes. I have placed a new build of Global Mapper 9 with the fix at http://www.globalmapper.com/global_mapper9.zip . Simply download that file and extract the contents over your existing v9.xx installation to give it a try.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • My Batch file

    @echo off

    "C:\11\GlobalMapper\global_mapper.exe" "C:\11\13.gms"

    But it not working. Help me