Reprojecting Lat / Lon WGS84 to UTM

JimWil2JimWil2 Global Mapper UserPosts: 4
edited May 2008 in Raster Data
Hi,
I have several landsat tiles in lat/lon wgs 84. They display seamlessly in Global mapper. When I open a mapinfo tab file of some vector data ( wgs 84 lat lon as well) with the raster as a background the vector file is distorted. So I change the projection in the Configuration menu to UTM with the correct zone and all is well. Excellent...

But now I want to export the raster tiles in UTM so that they also display correctly in other mapping programs ( Mapinfo). So in the file menu I choose Batch reproject / convert, choose the format (GeoTiFF) to convert from, choose the format to convert to (Geotiff raster imagery), choose the correct UTM zone and it's converted.

BUT when I open several tiles up in mapinfo the tiles have been slightly skewed ( OK, different datums I suspect) but the problem is that there is now a yellow slive around the 2 corners where there are no pixels and when 2 images are displayed together this yellow sliver obscures an area of the negibouring tile. Clear as mud?

So the question is:
1. Am I doing this correctly?
2. If so how can I get rid of the yellow areas ( no data areas?) Can I set them to transparent?

Any help much appreciated...
Jim

Comments

  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited May 2008
    Jim,

    The background border that you are seeing is a result of reprojecting the data. Since data that is rectangular in a lat/lon projection (like the Landsat data) will not be rectangular in most other projections, like UTM. Here is the FAQ item discussing this:

    Question: How come there is a thin border around exported DRGs (or image files) even after I have removed the collar in Global Mapper?

    Answer:
    The problem of an extra border around exported DRGs that have had the collar removed is caused by the fact that DRG Quads are NOT rectangular in the UTM projection after their collar has been removed. Rather, they are aligned on lat/lon grid boundaries, which makes them a little bit skewed when viewed in a UTM projection. Because the base TIFF and JPG formats only support rectangular images, something must be used to fill in the areas around the quad such that the data fills a rectangle. This extra fill causes the border to appear.

    One workaround for this problem is to reproject the images to Geographic before exporting them to a new file. This way the quads will be rectangular and you won't have the extra border around the data. You can change the projection for viewing and exporting the data by using the Projection tab on the Tools->Configuration dialog. See the earlier FAQ question for more details.

    Another option is to use a format that supports transparency, like PNG or 24-bit RGB GeoTIFF, when doing your export, thus allowing Global Mapper to mark those border pixels as transparent on export. Note however that not all applications can handle image files with built-in transparency.


    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • JimWil2JimWil2 Global Mapper User Posts: 4
    edited May 2008
    Mike thanks for the helpful reply. I did read the FAQ but I'm still getting my head around all the issues.

    I tried your first suggestion with no sucess - obviously I'm missing something.

    1. Open the original image ( landsat, 15m pixels, lat/lon wgs 84) in GM.
    2. Change the projection to Geographic in the configure menu.
    3. File -> export the geotiff to a new file,
    4. Open the new geotiff in GM, change projestion to UTM zone 35, export the geotiff to a new file.
    5. open in mapinfo - adjacent images still have edges obscured by it's neighbours null areas.

    Have I got this right or missed a step or 2?

    TIA,
    Jim
  • global_mapperglobal_mapper Administrator Posts: 17,238
    edited May 2008
    Jim,

    When you do step 4 that is when the border is being added because an image that is rectangular in lat/lon (Geographic) will NOT be rectangular in UTM, hence the extra border. If you just open your lat/lon Landsat file, change the projection to UTM, then export to a GeoTIFF file and make sure to check the option to generate a 24-bit RGB GeoTIFF file and check the option to make background pixels transparent, then you should get a GeoTIFF file with the border pixels marked as transparent via an alpha channel. Many applications (like Global Mapper) will recognize that alpha channel and automatically make those border pixels transparent, but not all will.

    Let me know if I can be of further assistance.

    Thanks,

    Mike
    Global Mapper Support
    support@globalmapper.com
  • JimWil2JimWil2 Global Mapper User Posts: 4
    edited May 2008
    Thanks - that did the trick.

    Your mention that some apps support transparent pixels reminded me that mapinfo allows you to pick a transparent colour - so I picked the colour in the borders, that set them to transparent and all is well.

    Thanks very much. GM is a really powerful, flexible program.

    Jim
Sign In or Register to comment.