Global Mapper v25.0

combination process not working

JSL
JSL Global Mapper UserTrusted User

I used the "Close gaps" process to reduce the gaps between two polygons, but when I then tried to combine them, one of the polygons disappeared:

Original polygons:

After selecting and combining:

Attached is a workspace with the two polygons.

Thanks for any help.

Answers

  • JeffH@BMG
    JeffH@BMG Global Mapper Developer Trusted User


    Hi JSL,

    Looks like the blue polygon is problematic -- it seems to be self-intersecting in in a couple of places. In the first screen cap, they're located where the large blue dots are, on the underside of the blue polygon (not the one down by the red polygon):




    Here's a closeup of the one on the left:


    Here's the one on the right:


    Looks like Combine is dropping the invalid polygon, leaving only the red one. What version of Global Mapper are you running?

    Best regards,

    ~Jeff

  • JSL
    JSL Global Mapper User Trusted User

    24

  • JSL
    JSL Global Mapper User Trusted User
    Answer ✓

    I ran all the polygons through the Fix Invalid Areas process until no invalid polygons were left, and then I was able to combine them.


    Thanks!