Global Mapper v24.0

Problem exporting GeoJSON to GMP file

Hunter Geophysics
Hunter Geophysics Global Mapper UserTrusted User

Hello,

I have received a GeoJSON file from a third-party who is helping out with a project. This is the first time I've used GeoJSON files so I'm not overly familiar with them.

I imported the file into a new Global Mapper project just fine (Global Mapper appears to have assumed WGS84 as the datum). I then went to the Configure menu then Projection, and set the projection needed for my project (it was originally Geographic projection, WGS84 datum, and I changed it to MGA/Map Grid of Australia, zone 55, GDA 2020 datum). I don't know if this is the correct way to do this...

I then tried to export the project to a Global Mapper Package File. I have "all loaded data" selected in the "Export bounds" tab.

When I click ok to export, I get an error "no compatible and exportable data is available for export within the specified export bounds" and it doesn't work. I've been through and checked every setting within the export screen is identical to what I would normally use when exporting to GMP file, but this doesn't seem to want to work.

I then started all over again, created a new project, imported the GeoJSON and exported to GMP without changing the projection and that worked fine.

I then went ahead and changed the projection and tried to re-export... and it failed again with the same error message.


  1. Am I importing and re-projecting this data correctly?
  2. Any suggestions please on how to export to GMP file with the desired display projection?
  3. Does the GeoJSON file contain the datum in the file itself? Or has Global Mapper incorrectly assumed WGS84 in the absence of any datum information? (Is it possible the GeoJSON was actually using GDA2020 datum instead?)

Many thanks,

David

Answers

  • Hunter Geophysics
    Hunter Geophysics Global Mapper User Trusted User

    Update: my data provider advised that it was in WGS84, and then also provided me with a copy in GDA94. I was able to load the GDA94 GeoJSON file and export it without any problems whatsoever, even having changed the display projection to GDA2020.

    All sorted.

    ...it does seem weird though that I couldn't export the WGS84 GeoJSON to a GMP file...

Sign In or Register to comment.