Global Mapper v24.0

Improper Character Handling - Attribute Table

tfitz2001
tfitz2001 Global Mapper UserTrusted User

Been an issue in some form for several versions. GM is unable to handle some language characters when importing / copying attributes from one layer to another, perhaps an improper UTF-8 handling. This time the language is French and the importation of the characters: é, à, è, ù, â, ê, î, ô.

These characters can be viewed normally when importing a shapefile:


However, copying these attributes to another layer results in significant errors, in this case, every French accent is read as an error.


Export carries the errors out to the resulting file, requiring significant post-processing work.

Answers

  • tfitz2001
    tfitz2001 Global Mapper User Trusted User

    Failed to mention... x64 GM v23.1 (b030322) running on a Win 10 system

  • tfitz2001
    tfitz2001 Global Mapper User Trusted User

    Any update on this? Proving to be a real headache!


    Anyone else experience this issue with characters?

  • Global Mapper doesn't display Cyrillic characters properly. It also has problems importing files that use Cyrillic characters.

    I have put in several requests for a fix since at least 2018 but no sign of a fix so far. When I contacted supported they suggested changing the system language for non-Unicode applications to the language required. This only caused a lot of other issues for me so I personally don't recommend it.

    Because of this issue we are unable to work with large large amounts of data, so it is forcing our company to look to other GIS software. We have 45 offices worldwide so this has a huge impact on us.

  • I don't quite agree with you!))

  • My apologies but I did not know you could change the Default Character Set. That nugget of information would have been very useful when I contacted support 🙄

    I changed the Default Character Set to Russian/Cyrillic but this has made no difference to the import problems and display of the attribute values in the Attribute Editor.

    I am still unable to load a file with Cyrillic text in the filename until I rename it to English. When you have to load many dataset this become impractical. When I rename a file it will load, but the Attribute Editor displays question marks unless the characters are numbers.

    That said, it now displays the Russian labels so that's very helpful - I just need to learn Russian now 😃


  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User
    edited June 16

    For proper display of text inside of Global Mapper, rather than changing the Default Character Set, you want to set the Label/Attribute Language (Code Page) setting on the Labels tab of the Options dialog for the layer. The Russian / Cyrillic (CP: 1251) option is likely the correct one for your data, but it might also be UTF-8.

    For file format that specify the code page of the data (Shapefiles often do), we automatically set this on load. For other formats, the code page is just set to the system code page, so you need to then select the proper code page on the Options dialog for the layer if any non-ASCII characters are present.

    The issue loading files with characters that aren't displayable in the current system code page is a known issue (GM-1750 in our system) due to Global Mapper not being a native Unicode application. One workaround that in theory should work for any filename is to set your system code page for non-Unicode applications to UTF-8.

    This should make any filename displayable, but this is still a Beta Windows feature and might cause issues with some other non-Unicode applications that don't deal with UTF-8.

    Thanks,

    Mike

    Global Mapper Guru

  • tfitz2001
    tfitz2001 Global Mapper User Trusted User

    Late to the party on this. However, this workaround blows up character recognition across my windows platform. So a proper solution still remains elusive. Will continue having to manually adjust things.

Sign In or Register to comment.