Global Mapper v24.0

Smooth DTM and hillshading

Hello,

I have classified a very steep terrain ( up to 90% slope ). Because of the many trees and the steepness, not all ground points could be classified correctly. After the automatic classification, I used the "Path Profile" tool to manually classify all outliers. Now I have created a DTM (DTM and Settings can be seen on the screenshots). I am not completely satisfied with the result, because there are still many outliers distorting the 3D image (screenshot). Also, I don't manage to generate a classic gray terrain shading (My current actual settings of the shader can be seen in a screenshot). You can't see the terrain structure well because of the noise. I have experience with Qgis and ArcMap. So in Qgis I managed to generate a suitable terrain visualization (last screenshot). However, I want to do all the processing with Global Mapper. So my questions are:


1.) Can I classify the terrain even better?

2.) Can I smooth the terrain so that I get a nicer surface?

3.) What settings do I need to make so that I get a similar result to this one from Qgis?


Greetings,

Sandro


Answers

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    You might play with the Resampling method for the generated terrain layer on the Options dialog for the layer. You could try one of the Box Minimum resamplers (varying sizes are available), or maybe the Gaussian Blur or Filter/Noise/Median methods.

    For the shading, what QGIS has looks like the Daylight Shader in Global Mapper with a white or light gray color selected as the Surface Color (Shader Options tab of Configuration dialog). Maybe make the Shadow Darkness setting lighter as well.

  • Thank you! I got a good solution now!

  • And do please pray tell what was this magical solution? where is this no matter what I every time I generate a DTM I get massive stepping and artificial gridding, and this is a flat slopey area (A ramp road) with no trees and over 400pts of lidar per m2, I'm not sure why GM always makes very "chunky" stepping instead of smooth curves, even when I set the DTM resolution at 10cm per point its still "Chunky".

    Any suggestions are definitely appreciated


  • Tried changing the resample and blend mode options as suggested, all it does is simulate that I took off my glasses, the stepping and gridding is still there, anyone know what I'm doing wrong? thanks for the help



  • Treebeard
    Treebeard Global Mapper User Trusted User

    could it be that your raster is integer based vs. floating point?

  • I have not tried this... however im making this from a LAZ file then converted into a GMP DTM and also USGS DEM, it was never originally sourced from a raster.

    Unless you mean changing the DTM layer in GM to display as floating point.

    The image you are seeing is not a raster but a graphical representation of a DTM vector map, GM does that view on its own, unless there's a way to change it somehow.

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    Typically a stair-step appearance is caused by the native resolution stored by the grid layer. This is often an issue on things like USGS DEM or GMG format exports that store elevations as whole numbers in the specified unit. Users would often choose a large whole unit, like meters or feet, and thus their values would be rounded to the nearest whole unit and have large stair steps. Exporting instead in centimeters or millimeters would give sufficient resolution for most data.

    The hill shading can often show something like the grid pattern you are seeing when there are very subtle steps in elevation. If you use the Path Profile tool and draw a path over one of the visible steps you might see that the step is very tiny (well below your error), but just large enough for the hill shading to add a small shadow. So it's a visual artifact vs. an actual issue in the terrain values.

    Thanks,

    Mike

    Global Mapper Guru

Sign In or Register to comment.