Global Mapper v25.0

Empty rows after spatially thinning LIDAR.

mcweb
mcweb Global Mapper User

I have a lidar .las file that is too dense. When I try to spatially thin it, it creates what looks like empty rows.

I am trying to thin to 20'± spacing, using minimum elevation settings. Roughly, evenly spaced grid.

This process does not seam to create the result I am looking for. Am I using it correctly, or is there something wrong with my data?

Global Mapper 20.1.

Please see attached screen shots, before and after.



Answers

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    What happens when you spatially thin Lidar using the Minimum Elevation setting is the following:

    • a regular grid at the specified spacing is set up
    • all Lidar points inside each grid cell are evaluated. The full Lidar return that contains the minimum elevation of all of the points in that grid cell is kept. That Lidar point could be anywhere inside the cell, it will not be moved to the center.

    What this means is that if you have something like a horizontally assigned low area (like a ditch) that is along the spacing boundary and is small compared to the spacing, you might end up with a series of points close to each other but in different cells being the minimum elevation points that are kept.

    If you want to just get minimum points re-centered in each sample location, you could instead create an elevation grid from the Lidar with the minimum setting and the same spacing. Once you have the grid, use the Layer -> Terrain / Point Cloud -> Create Point Features at Elevation Grid Cell Centers command to create a new Lidar point cloud from the cell center points.

  • sjf
    sjf Global Mapper User

    Just a question MC,

    Do you also use scan angle to spatially thin the las file? I find that in lidar data from multiple runs with overlap removing the scan angles on the outsides (roughly the outer scan angles in the overlap area) to give the best results (height) and spatially thin the point cloud.

    Later this can be analysed to use minimum values, binning etc. and create a grid.

    greetings Stefan

  • Hello Stefan,

    how do you remove points with a high scan angle? I am with you. I also get the best results by removing the scan angles on the outsides. But my proglem is, that Global Mapper cannot handle big clouds. That means, that i need to thin my point cloud before removing all points with high scan angle. I remove them using the "attribute editor". However, it can only create queries if the point cloud has no more than about 10,000,000 points. Do you use another workflow to remove those points?


    greetings Sandro

  • mcweb
    mcweb Global Mapper User

    I now use Cloud Compare for this task.

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    Note that there was a bug in the spatial thinning in Lidar that would cause the empty rows. The more non-square the area being thinned was, the larger the issue. This was fixed a couple of versions back.

    Thanks,

    Mike

    Global Mapper Guru