Global Mapper Pro

Problem with character encoding

darrepac
darrepac Global Mapper User

Hi


I open a shapefile (french text).

In it, everything i well written, example:

If I look into metadata, it is using UTF8:

then I want to export this shape and split by NAME. I choose UTF8 coding (I tried others) but the filename is always weird:

Any hint?


thanks

Best Answer

  • bmg_mike
    bmg_mike Global Mapper Guru
    Accepted Answer

    I'm fixing this now (todo item GM-13273) to be in the 23.1.x daily builds after the 23.1 release this week.

    As a workaround, if you first export your data without splitting to code page 1252 (or whatever your system code page is, but 1252 is likely what you are using in France), then load that file back in and split by name on export, then the filenames should be fine.

Answers

  • darrepac
    darrepac Global Mapper User

    Thanks! workaround works well!

  • I have downloaded the latest daily build but I am unable to successfully import data that contains Cyrillic text. Global Mapper will not import a DWG if it contains Cyrillic text, unless you rename every file to english first. Then when you import the DWG all the characters are messed up.

    I have been asking support for years to be able to import data with Cyrillic text but it doesn't look like this is going to happen soon or at all. Unfortunately this means we are unable to import most of the global datasets we work with. As we are unable to import global dataset we have started moving over to ArcGIS Pro. It's a shame that Blue Marble hasn't fully implemented the G in GIS yet.

  • bmg_mike
    bmg_mike Global Mapper Guru Moderator, Trusted User

    You should be able to open filenames with Cyrillic characters if your system non-Unicode filename is set to a language that natively displays them.

    To change this setting, do the following (instructions on Windows 11, but should be similar on others):

    1) Open the Region Settings in Windows

    2) Go to the Administrative tab

    3) Press 'Change system locale'

    4) Either change the System Locale to one that natively displays Cyrillic (like Russian), or check the 'Beta: Use Unicode UTF-8 for worldwide language support'. The latter option is in Beta, but in theory would let you load any filename.

    5) Reboot when prompted

    For displaying the text properly in Global Mapper, if the file doesn't contain information that GM recognizes to set the code page of the layer, you will need to manually select the proper code page on the Options dialog for the layer after load.

    If you can provide a sample DWG that doesn't display with the correct code page at load, I can take a look and see why the code page isn't being read from the header.

  • Hi Mike,

    I had already tried this workaround but it just caused us other issues outside of Global Mapper. What we need is a Global Mapper side solution. We don't have any issues with other GIS applications so assumed this is something that could be addressed within the software.

Sign In or Register to comment.